aboutsummaryrefslogtreecommitdiffstats
path: root/modules/online-accounts/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-06-10 04:28:36 +0800
committerRodrigo Moya <rodrigo@gnome-db.org>2011-06-30 00:42:32 +0800
commitd9323c2872320bfb5ee7498fd8f384d78c4b99cf (patch)
tree7c4081aee7cec6cfe8394323ff06fd4dc3a8ffb1 /modules/online-accounts/Makefile.am
parent1b93c1cf3822929fa3c43279c36646a76bcbc5ee (diff)
downloadgsoc2013-evolution-d9323c2872320bfb5ee7498fd8f384d78c4b99cf.tar
gsoc2013-evolution-d9323c2872320bfb5ee7498fd8f384d78c4b99cf.tar.gz
gsoc2013-evolution-d9323c2872320bfb5ee7498fd8f384d78c4b99cf.tar.bz2
gsoc2013-evolution-d9323c2872320bfb5ee7498fd8f384d78c4b99cf.tar.lz
gsoc2013-evolution-d9323c2872320bfb5ee7498fd8f384d78c4b99cf.tar.xz
gsoc2013-evolution-d9323c2872320bfb5ee7498fd8f384d78c4b99cf.tar.zst
gsoc2013-evolution-d9323c2872320bfb5ee7498fd8f384d78c4b99cf.zip
Prototype an online-accounts module.
Integrates with the GNOME Online Accounts service. Creates Evolution sources for a GOA Google account and keeps them synchronized. Also registers a new CamelSaslXOAuth class for use with GMail. Authentication of Google Calendars and Google Contacts using OAuth is still under development.
Diffstat (limited to 'modules/online-accounts/Makefile.am')
-rw-r--r--modules/online-accounts/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/modules/online-accounts/Makefile.am b/modules/online-accounts/Makefile.am
new file mode 100644
index 0000000000..a5dfd97a0b
--- /dev/null
+++ b/modules/online-accounts/Makefile.am
@@ -0,0 +1,32 @@
+module_LTLIBRARIES = libevolution-module-online-accounts.la
+
+libevolution_module_online_accounts_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"evolution-online-accounts\" \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(EVOLUTION_ADDRESSBOOK_CFLAGS) \
+ $(EVOLUTION_CALENDAR_CFLAGS) \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(GOA_CFLAGS)
+
+libevolution_module_online_accounts_la_SOURCES = \
+ evolution-online-accounts.c \
+ e-online-accounts-google.c \
+ e-online-accounts-google.h \
+ camel-sasl-xoauth.c \
+ camel-sasl-xoauth.h
+
+libevolution_module_online_accounts_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/shell/libeshell.la \
+ $(GNOME_PLATFORM_LIBS) \
+ $(EVOLUTION_ADDRESSBOOK_LIBS) \
+ $(EVOLUTION_CALENDAR_LIBS) \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GOA_LIBS)
+
+libevolution_module_online_accounts_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk