aboutsummaryrefslogtreecommitdiffstats
path: root/modules/mail/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-05-29 00:36:37 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-05-29 00:50:18 +0800
commit005ac1efa32c7e3a3dc5eb959b69fdee5fb91320 (patch)
treeb7eaca0fc61577360d34e35464465d7232e4b414 /modules/mail/Makefile.am
parent2c9f0932e8c2bc100f8ec7335a20fbfecea052a2 (diff)
downloadgsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.gz
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.bz2
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.lz
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.xz
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.tar.zst
gsoc2013-evolution-005ac1efa32c7e3a3dc5eb959b69fdee5fb91320.zip
Make the settings capplet optional.
The evolution-settings capplet was originally designed for Anjal, it was used in MeeGo as part of the Express Mode effort, but doesn't really fit in GNOME 3 nowadays (nor did it really fit in GNOME 2, in my opinion). Add a --with-capplet configure switch defaulting to 'no'. The capplet will eventually be removed unless I see someone actively maintaining it.
Diffstat (limited to 'modules/mail/Makefile.am')
-rw-r--r--modules/mail/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/modules/mail/Makefile.am b/modules/mail/Makefile.am
index 25b5b15ef4..7d7f298b6c 100644
--- a/modules/mail/Makefile.am
+++ b/modules/mail/Makefile.am
@@ -49,6 +49,11 @@ module_mail_la_SOURCES = \
em-network-prefs.c \
em-network-prefs.h
+if WITH_CAPPLET
+libevolution_mail_settings_la = \
+ $(top_builddir)/capplet/settings/libevolution-mail-settings.la
+endif
+
module_mail_la_LIBADD = \
$(top_builddir)/libemail-utils/libemail-utils.la \
$(top_builddir)/libemail-engine/libemail-engine.la \
@@ -66,8 +71,8 @@ module_mail_la_LIBADD = \
$(top_builddir)/em-format/libemformat.la \
$(top_builddir)/widgets/menus/libmenus.la \
$(top_builddir)/filter/libfilter.la \
- $(top_builddir)/capplet/settings/libevolution-mail-settings.la \
$(top_builddir)/libevolution-utils/libevolution-utils.la \
+ $(libevolution_mail_settings_la) \
$(EVOLUTION_DATA_SERVER_LIBS) \
$(GNOME_PLATFORM_LIBS) \
$(GTKHTML_LIBS)