aboutsummaryrefslogtreecommitdiffstats
path: root/modules/imap-features/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-03-16 11:56:12 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:42 +0800
commit209e47b133349dc29c3eb68b9d4b5ac3465e0a0d (patch)
tree930b2a5d1e14bf2bc0ca3e56b0a8ec490496c5c6 /modules/imap-features/Makefile.am
parent3efee090f0f57828edd05210f1a709f4eb4a926a (diff)
downloadgsoc2013-evolution-209e47b133349dc29c3eb68b9d4b5ac3465e0a0d.tar
gsoc2013-evolution-209e47b133349dc29c3eb68b9d4b5ac3465e0a0d.tar.gz
gsoc2013-evolution-209e47b133349dc29c3eb68b9d4b5ac3465e0a0d.tar.bz2
gsoc2013-evolution-209e47b133349dc29c3eb68b9d4b5ac3465e0a0d.tar.lz
gsoc2013-evolution-209e47b133349dc29c3eb68b9d4b5ac3465e0a0d.tar.xz
gsoc2013-evolution-209e47b133349dc29c3eb68b9d4b5ac3465e0a0d.tar.zst
gsoc2013-evolution-209e47b133349dc29c3eb68b9d4b5ac3465e0a0d.zip
Add 'imap-features' module.
Adds an extra page to EMailConfigNotebook for 'imap' accounts. Replaces the 'imap-features' plugin.
Diffstat (limited to 'modules/imap-features/Makefile.am')
-rw-r--r--modules/imap-features/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/modules/imap-features/Makefile.am b/modules/imap-features/Makefile.am
new file mode 100644
index 0000000000..d49ddfa287
--- /dev/null
+++ b/modules/imap-features/Makefile.am
@@ -0,0 +1,33 @@
+NULL =
+
+module_LTLIBRARIES = module-imap-features.la
+
+module_imap_features_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-imap-features\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(NULL)
+
+module_imap_features_la_SOURCES = \
+ evolution-imap-features.c \
+ e-mail-config-header-manager.c \
+ e-mail-config-header-manager.h \
+ e-mail-config-imap-headers-page.c \
+ e-mail-config-imap-headers-page.h \
+ $(NULL)
+
+module_imap_features_la_LIBADD = \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/libemail-engine/libemail-engine.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(NULL)
+
+module_imap_features_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk