aboutsummaryrefslogtreecommitdiffstats
path: root/modules/gravatar/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-04-26 00:30:11 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-04-26 08:17:20 +0800
commit91aee2a805d70c9f7a5f0d089139fbfc710939c1 (patch)
treebec4108805f99ca0f244a26180b0c487b9f4eaca /modules/gravatar/Makefile.am
parent009ac971e069ced92547800a78ab3119f733c333 (diff)
downloadgsoc2013-evolution-91aee2a805d70c9f7a5f0d089139fbfc710939c1.tar
gsoc2013-evolution-91aee2a805d70c9f7a5f0d089139fbfc710939c1.tar.gz
gsoc2013-evolution-91aee2a805d70c9f7a5f0d089139fbfc710939c1.tar.bz2
gsoc2013-evolution-91aee2a805d70c9f7a5f0d089139fbfc710939c1.tar.lz
gsoc2013-evolution-91aee2a805d70c9f7a5f0d089139fbfc710939c1.tar.xz
gsoc2013-evolution-91aee2a805d70c9f7a5f0d089139fbfc710939c1.tar.zst
gsoc2013-evolution-91aee2a805d70c9f7a5f0d089139fbfc710939c1.zip
Add a gravatar module.
This is a new EPhotoSource that obtains images from gravatar.com.
Diffstat (limited to 'modules/gravatar/Makefile.am')
-rw-r--r--modules/gravatar/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/gravatar/Makefile.am b/modules/gravatar/Makefile.am
new file mode 100644
index 0000000000..47c9e6570b
--- /dev/null
+++ b/modules/gravatar/Makefile.am
@@ -0,0 +1,30 @@
+module_LTLIBRARIES = module-gravatar.la
+
+module_gravatar_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -DG_LOG_DOMAIN=\"evolution-gravatar\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(NULL)
+
+module_gravatar_la_SOURCES = \
+ evolution-module-gravatar.c \
+ e-gravatar-photo-source.c \
+ e-gravatar-photo-source.h \
+ e-photo-cache-gravatar-loader.c \
+ e-photo-cache-gravatar-loader.h \
+ $(NULL)
+
+module_gravatar_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(NULL)
+
+module_gravatar_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk