aboutsummaryrefslogtreecommitdiffstats
path: root/modules/composer-autosave/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-09-03 01:21:08 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-09-03 01:37:31 +0800
commit429234ff213ba04b6d0b02a28ed68aaa8af7c02c (patch)
tree69fd485d98a78148137ab29e5c1e8d16add7c0f1 /modules/composer-autosave/Makefile.am
parentcccdb143a571cde36db9fe906864647aab546cff (diff)
downloadgsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.gz
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.bz2
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.lz
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.xz
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.tar.zst
gsoc2013-evolution-429234ff213ba04b6d0b02a28ed68aaa8af7c02c.zip
Convert composer autosave to an EExtension.
Given the way the autosave feature was awkwardly bolted on to the composer, an EExtension seemed like a natural fit. And it helped clean up some object lifecycle hacks (and bugs). What we have now is a new module consisting of two EExtensions: EComposerAutosave extends EMsgComposer and determines when to kick off an asynchronous autosave operation. EComposerRegistry extends EShell and offers to restore orphaned autosave files on startup (which is also asynchronous now). e-autosave-utils.c holds the actual asynchronous functions and a few other miscellaneous utility functions. Source code for the new module lives in /modules/composer-autosave.
Diffstat (limited to 'modules/composer-autosave/Makefile.am')
-rw-r--r--modules/composer-autosave/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/composer-autosave/Makefile.am b/modules/composer-autosave/Makefile.am
new file mode 100644
index 0000000000..0b802e11bf
--- /dev/null
+++ b/modules/composer-autosave/Makefile.am
@@ -0,0 +1,28 @@
+module_LTLIBRARIES = libevolution-module-composer-autosave.la
+
+libevolution_module_composer_autosave_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-composer-autosave\" \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
+
+libevolution_module_composer_autosave_la_SOURCES = \
+ evolution-composer-autosave.c \
+ e-autosave-utils.c \
+ e-autosave-utils.h \
+ e-composer-autosave.c \
+ e-composer-registry.c
+
+libevolution_module_composer_autosave_la_LIBADD = \
+ $(top_builddir)/shell/libeshell.la \
+ $(top_builddir)/composer/libcomposer.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(EVOLUTION_MAIL_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+libevolution_module_composer_autosave_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk