aboutsummaryrefslogtreecommitdiffstats
path: root/modules/cal-config-webcal/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-02-04 21:46:37 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:42 +0800
commit3efee090f0f57828edd05210f1a709f4eb4a926a (patch)
treeedf02d2bbfb531984771fa92ff517e7ad71f1ccc /modules/cal-config-webcal/Makefile.am
parentd21230f743de72ff73ed4aa22149175346d4d6ce (diff)
downloadgsoc2013-evolution-3efee090f0f57828edd05210f1a709f4eb4a926a.tar
gsoc2013-evolution-3efee090f0f57828edd05210f1a709f4eb4a926a.tar.gz
gsoc2013-evolution-3efee090f0f57828edd05210f1a709f4eb4a926a.tar.bz2
gsoc2013-evolution-3efee090f0f57828edd05210f1a709f4eb4a926a.tar.lz
gsoc2013-evolution-3efee090f0f57828edd05210f1a709f4eb4a926a.tar.xz
gsoc2013-evolution-3efee090f0f57828edd05210f1a709f4eb4a926a.tar.zst
gsoc2013-evolution-3efee090f0f57828edd05210f1a709f4eb4a926a.zip
Add 'cal-config-webcal' module.
Registers the "On The Web" backend in ECalSourceConfig widgets. Replaces the 'calendar-http' plugin.
Diffstat (limited to 'modules/cal-config-webcal/Makefile.am')
-rw-r--r--modules/cal-config-webcal/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/cal-config-webcal/Makefile.am b/modules/cal-config-webcal/Makefile.am
new file mode 100644
index 0000000000..ef96ebfece
--- /dev/null
+++ b/modules/cal-config-webcal/Makefile.am
@@ -0,0 +1,24 @@
+module_LTLIBRARIES = module-cal-config-webcal.la
+
+module_cal_config_webcal_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-cal-config-webcal\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
+
+module_cal_config_webcal_la_SOURCES = \
+ evolution-cal-config-webcal.c
+
+module_cal_config_webcal_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/calendar/gui/libevolution-calendar.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+module_cal_config_webcal_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk