aboutsummaryrefslogtreecommitdiffstats
path: root/modules/cal-config-weather/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-02-04 21:49:12 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:42 +0800
commitd21230f743de72ff73ed4aa22149175346d4d6ce (patch)
tree4ee17bbfe83bcafce7f229362e2535201c44abf9 /modules/cal-config-weather/Makefile.am
parentc030e2f0a57ee68c5a512df0cd0cea06346a50bc (diff)
downloadgsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.gz
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.bz2
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.lz
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.xz
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.tar.zst
gsoc2013-evolution-d21230f743de72ff73ed4aa22149175346d4d6ce.zip
Add 'cal-config-weather' module.
Registers the "Weather" backend in ECalSourceConfig widgets. Replaces the 'calendar-weather' plugin.
Diffstat (limited to 'modules/cal-config-weather/Makefile.am')
-rw-r--r--modules/cal-config-weather/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/cal-config-weather/Makefile.am b/modules/cal-config-weather/Makefile.am
new file mode 100644
index 0000000000..54b6d1e0e0
--- /dev/null
+++ b/modules/cal-config-weather/Makefile.am
@@ -0,0 +1,28 @@
+module_LTLIBRARIES = module-cal-config-weather.la
+
+module_cal_config_weather_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-cal-config-weather\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GWEATHER_CFLAGS)
+
+module_cal_config_weather_la_SOURCES = \
+ evolution-cal-config-weather.c \
+ e-source-weather.c \
+ e-source-weather.h
+
+module_cal_config_weather_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/calendar/gui/libevolution-calendar.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GWEATHER_LIBS)
+
+module_cal_config_weather_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk