aboutsummaryrefslogtreecommitdiffstats
path: root/modules/cal-config-local/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-01-20 03:41:02 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:41 +0800
commitcb1220aff2c8c78246432229b875b7de6d44de84 (patch)
tree0e6648380a86e86325c62729c7ad637ce6437248 /modules/cal-config-local/Makefile.am
parent8b03b8a20cd20c343979dea3013a05600ad2f6ec (diff)
downloadgsoc2013-evolution-cb1220aff2c8c78246432229b875b7de6d44de84.tar
gsoc2013-evolution-cb1220aff2c8c78246432229b875b7de6d44de84.tar.gz
gsoc2013-evolution-cb1220aff2c8c78246432229b875b7de6d44de84.tar.bz2
gsoc2013-evolution-cb1220aff2c8c78246432229b875b7de6d44de84.tar.lz
gsoc2013-evolution-cb1220aff2c8c78246432229b875b7de6d44de84.tar.xz
gsoc2013-evolution-cb1220aff2c8c78246432229b875b7de6d44de84.tar.zst
gsoc2013-evolution-cb1220aff2c8c78246432229b875b7de6d44de84.zip
Add 'cal-config-local' module.
Registers the "On This Computer" backend in ECalSourceConfig widgets. Replaces the 'calendar-file' plugin.
Diffstat (limited to 'modules/cal-config-local/Makefile.am')
-rw-r--r--modules/cal-config-local/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/modules/cal-config-local/Makefile.am b/modules/cal-config-local/Makefile.am
new file mode 100644
index 0000000000..3cd8f6d18a
--- /dev/null
+++ b/modules/cal-config-local/Makefile.am
@@ -0,0 +1,26 @@
+module_LTLIBRARIES = module-cal-config-local.la
+
+module_cal_config_local_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-cal-config-local\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
+
+module_cal_config_local_la_SOURCES = \
+ evolution-cal-config-local.c \
+ e-source-local.c \
+ e-source-local.h
+
+module_cal_config_local_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/calendar/gui/libevolution-calendar.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+module_cal_config_local_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk