aboutsummaryrefslogtreecommitdiffstats
path: root/modules/cal-config-google/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-02-04 21:52:28 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:41 +0800
commitc030e2f0a57ee68c5a512df0cd0cea06346a50bc (patch)
treeb3c3709228af8179c10f0183a72f79a6930f37a0 /modules/cal-config-google/Makefile.am
parent1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf (diff)
downloadgsoc2013-evolution-c030e2f0a57ee68c5a512df0cd0cea06346a50bc.tar
gsoc2013-evolution-c030e2f0a57ee68c5a512df0cd0cea06346a50bc.tar.gz
gsoc2013-evolution-c030e2f0a57ee68c5a512df0cd0cea06346a50bc.tar.bz2
gsoc2013-evolution-c030e2f0a57ee68c5a512df0cd0cea06346a50bc.tar.lz
gsoc2013-evolution-c030e2f0a57ee68c5a512df0cd0cea06346a50bc.tar.xz
gsoc2013-evolution-c030e2f0a57ee68c5a512df0cd0cea06346a50bc.tar.zst
gsoc2013-evolution-c030e2f0a57ee68c5a512df0cd0cea06346a50bc.zip
Add 'cal-config-google' module.
Registers the "Google" backend in ECalSourceConfig widgets. Replaces the 'google-account-setup' plugin.
Diffstat (limited to 'modules/cal-config-google/Makefile.am')
-rw-r--r--modules/cal-config-google/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/modules/cal-config-google/Makefile.am b/modules/cal-config-google/Makefile.am
new file mode 100644
index 0000000000..f79565a5cc
--- /dev/null
+++ b/modules/cal-config-google/Makefile.am
@@ -0,0 +1,32 @@
+module_LTLIBRARIES = module-cal-config-google.la
+
+module_cal_config_google_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-cal-config-google\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GDATA_CFLAGS)
+
+module_cal_config_google_la_SOURCES = \
+ evolution-cal-config-google.c \
+ e-google-chooser-button.c \
+ e-google-chooser-button.h \
+ e-google-chooser-dialog.c \
+ e-google-chooser-dialog.h \
+ e-google-chooser.c \
+ e-google-chooser.h
+
+module_cal_config_google_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/calendar/gui/libevolution-calendar.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GDATA_LIBS)
+
+module_cal_config_google_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk