aboutsummaryrefslogtreecommitdiffstats
path: root/modules/cal-config-contacts/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-01-20 04:23:12 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:41 +0800
commit1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf (patch)
tree0808ed3b5332606eae771911c0bb84fd4577d9db /modules/cal-config-contacts/Makefile.am
parent691ab73cd436d43883d7e3a2481f8ded9369af29 (diff)
downloadgsoc2013-evolution-1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf.tar
gsoc2013-evolution-1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf.tar.gz
gsoc2013-evolution-1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf.tar.bz2
gsoc2013-evolution-1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf.tar.lz
gsoc2013-evolution-1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf.tar.xz
gsoc2013-evolution-1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf.tar.zst
gsoc2013-evolution-1ad9dfdc9fcbb5e675210dd0de1de3b599d90bbf.zip
Add 'cal-config-contacts' module.
Registers the "Contacts" backend in ECalSourceConfig widgets.
Diffstat (limited to 'modules/cal-config-contacts/Makefile.am')
-rw-r--r--modules/cal-config-contacts/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/modules/cal-config-contacts/Makefile.am b/modules/cal-config-contacts/Makefile.am
new file mode 100644
index 0000000000..59367b9d57
--- /dev/null
+++ b/modules/cal-config-contacts/Makefile.am
@@ -0,0 +1,32 @@
+module_LTLIBRARIES = module-cal-config-contacts.la
+
+module_cal_config_contacts_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-cal-config-contacts\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
+
+module_cal_config_contacts_la_SOURCES = \
+ evolution-cal-config-contacts.c \
+ e-contacts-selector.c \
+ e-contacts-selector.h \
+ e-source-contacts.c \
+ e-source-contacts.h
+
+module_cal_config_contacts_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/addressbook/printing/libecontactprint.la \
+ $(top_builddir)/addressbook/gui/merging/libeabbookmerging.la \
+ $(top_builddir)/addressbook/gui/widgets/libeabwidgets.la \
+ $(top_builddir)/addressbook/util/libeabutil.la \
+ $(top_builddir)/calendar/gui/libevolution-calendar.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+module_cal_config_contacts_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk