aboutsummaryrefslogtreecommitdiffstats
path: root/modules/book-config-local/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-12-20 12:51:59 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:41 +0800
commit305b51db24b2ea740f67e068313e721c1b55f937 (patch)
treebc182ddbe62c17670455dc9ffd6594bfa7352144 /modules/book-config-local/Makefile.am
parentcd3759369b675e754dbed5ba19894cdd87a63a88 (diff)
downloadgsoc2013-evolution-305b51db24b2ea740f67e068313e721c1b55f937.tar
gsoc2013-evolution-305b51db24b2ea740f67e068313e721c1b55f937.tar.gz
gsoc2013-evolution-305b51db24b2ea740f67e068313e721c1b55f937.tar.bz2
gsoc2013-evolution-305b51db24b2ea740f67e068313e721c1b55f937.tar.lz
gsoc2013-evolution-305b51db24b2ea740f67e068313e721c1b55f937.tar.xz
gsoc2013-evolution-305b51db24b2ea740f67e068313e721c1b55f937.tar.zst
gsoc2013-evolution-305b51db24b2ea740f67e068313e721c1b55f937.zip
Add 'book-config-local' module.
Registers the "On This Computer" backend in EBookSourceConfig widgets. Replaces the 'addressbook-file' plugin.
Diffstat (limited to 'modules/book-config-local/Makefile.am')
-rw-r--r--modules/book-config-local/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/book-config-local/Makefile.am b/modules/book-config-local/Makefile.am
new file mode 100644
index 0000000000..234b4825ad
--- /dev/null
+++ b/modules/book-config-local/Makefile.am
@@ -0,0 +1,27 @@
+module_LTLIBRARIES = module-book-config-local.la
+
+module_book_config_local_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-book-config-local\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
+
+module_book_config_local_la_SOURCES = \
+ evolution-book-config-local.c
+
+module_book_config_local_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/addressbook/printing/libecontactprint.la \
+ $(top_builddir)/addressbook/gui/merging/libeabbookmerging.la \
+ $(top_builddir)/addressbook/gui/widgets/libeabwidgets.la \
+ $(top_builddir)/addressbook/util/libeabutil.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+module_book_config_local_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk