aboutsummaryrefslogtreecommitdiffstats
path: root/modules/book-config-ldap/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-12-31 23:49:54 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:41 +0800
commit4c9c82d88483c36068756c0674020602b907d47e (patch)
tree4673acd1e278cf6f23eee13861ba918ac1ccb27b /modules/book-config-ldap/Makefile.am
parenta4607aee992c409da5ff5afa9f0222bbd1bebc29 (diff)
downloadgsoc2013-evolution-4c9c82d88483c36068756c0674020602b907d47e.tar
gsoc2013-evolution-4c9c82d88483c36068756c0674020602b907d47e.tar.gz
gsoc2013-evolution-4c9c82d88483c36068756c0674020602b907d47e.tar.bz2
gsoc2013-evolution-4c9c82d88483c36068756c0674020602b907d47e.tar.lz
gsoc2013-evolution-4c9c82d88483c36068756c0674020602b907d47e.tar.xz
gsoc2013-evolution-4c9c82d88483c36068756c0674020602b907d47e.tar.zst
gsoc2013-evolution-4c9c82d88483c36068756c0674020602b907d47e.zip
Add 'book-config-ldap' module.
Register the "On LDAP Servers" backend in EBookSourceConfig widgets.
Diffstat (limited to 'modules/book-config-ldap/Makefile.am')
-rw-r--r--modules/book-config-ldap/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/modules/book-config-ldap/Makefile.am b/modules/book-config-ldap/Makefile.am
new file mode 100644
index 0000000000..bcb9cd0695
--- /dev/null
+++ b/modules/book-config-ldap/Makefile.am
@@ -0,0 +1,31 @@
+module_LTLIBRARIES = module-book-config-ldap.la
+
+module_book_config_ldap_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-book-config-ldap\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(LDAP_CFLAGS)
+
+module_book_config_ldap_la_SOURCES = \
+ evolution-book-config-ldap.c \
+ e-source-ldap.c \
+ e-source-ldap.h
+
+module_book_config_ldap_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/addressbook/printing/libecontactprint.la \
+ $(top_builddir)/addressbook/gui/merging/libeabbookmerging.la \
+ $(top_builddir)/addressbook/gui/widgets/libeabwidgets.la \
+ $(top_builddir)/addressbook/util/libeabutil.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(LDAP_LIBS)
+
+module_book_config_ldap_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk