aboutsummaryrefslogtreecommitdiffstats
path: root/modules/book-config-google/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-12-30 12:36:47 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-06-03 11:00:41 +0800
commita4607aee992c409da5ff5afa9f0222bbd1bebc29 (patch)
treeaccdadd729327ef5236c66624c76a582660a4531 /modules/book-config-google/Makefile.am
parent305b51db24b2ea740f67e068313e721c1b55f937 (diff)
downloadgsoc2013-evolution-a4607aee992c409da5ff5afa9f0222bbd1bebc29.tar
gsoc2013-evolution-a4607aee992c409da5ff5afa9f0222bbd1bebc29.tar.gz
gsoc2013-evolution-a4607aee992c409da5ff5afa9f0222bbd1bebc29.tar.bz2
gsoc2013-evolution-a4607aee992c409da5ff5afa9f0222bbd1bebc29.tar.lz
gsoc2013-evolution-a4607aee992c409da5ff5afa9f0222bbd1bebc29.tar.xz
gsoc2013-evolution-a4607aee992c409da5ff5afa9f0222bbd1bebc29.tar.zst
gsoc2013-evolution-a4607aee992c409da5ff5afa9f0222bbd1bebc29.zip
Add 'book-config-google' module.
Register the "Google" backend in EBookSourceConfig widgets. Partially replaces the 'google-account-setup' plugin.
Diffstat (limited to 'modules/book-config-google/Makefile.am')
-rw-r--r--modules/book-config-google/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/book-config-google/Makefile.am b/modules/book-config-google/Makefile.am
new file mode 100644
index 0000000000..c3a290b240
--- /dev/null
+++ b/modules/book-config-google/Makefile.am
@@ -0,0 +1,27 @@
+module_LTLIBRARIES = module-book-config-google.la
+
+module_book_config_google_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ -DG_LOG_DOMAIN=\"evolution-book-config-google\" \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS)
+
+module_book_config_google_la_SOURCES = \
+ evolution-book-config-google.c
+
+module_book_config_google_la_LIBADD = \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/widgets/misc/libemiscwidgets.la \
+ $(top_builddir)/addressbook/printing/libecontactprint.la \
+ $(top_builddir)/addressbook/gui/merging/libeabbookmerging.la \
+ $(top_builddir)/addressbook/gui/widgets/libeabwidgets.la \
+ $(top_builddir)/addressbook/util/libeabutil.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS)
+
+module_book_config_google_la_LDFLAGS = \
+ -module -avoid-version $(NO_UNDEFINED)
+
+-include $(top_srcdir)/git.mk