aboutsummaryrefslogtreecommitdiffstats
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2011-06-10 04:28:36 +0800
committerMatthew Barnes <mbarnes@redhat.com>2011-06-25 07:05:15 +0800
commitdd6e64ad305e1ab181c6276ed4c77d910a36a4fa (patch)
treec04828633069b8c4e7531733d4960f58def4d762 /modules/Makefile.am
parentf070b6032f46dddb64220ee3ec26d79fa1bbe8bb (diff)
downloadgsoc2013-evolution-dd6e64ad305e1ab181c6276ed4c77d910a36a4fa.tar
gsoc2013-evolution-dd6e64ad305e1ab181c6276ed4c77d910a36a4fa.tar.gz
gsoc2013-evolution-dd6e64ad305e1ab181c6276ed4c77d910a36a4fa.tar.bz2
gsoc2013-evolution-dd6e64ad305e1ab181c6276ed4c77d910a36a4fa.tar.lz
gsoc2013-evolution-dd6e64ad305e1ab181c6276ed4c77d910a36a4fa.tar.xz
gsoc2013-evolution-dd6e64ad305e1ab181c6276ed4c77d910a36a4fa.tar.zst
gsoc2013-evolution-dd6e64ad305e1ab181c6276ed4c77d910a36a4fa.zip
Prototype an online-accounts module.
Integrates with the GNOME Online Accounts service. Creates Evolution sources for a GOA Google account and keeps them synchronized. Also registers a new CamelSaslXOAuth class for use with GMail. Authentication of Google Calendars and Google Contacts using OAuth is still under development.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index ae95614c2a..9a32c72ebc 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -6,6 +6,10 @@ if ENABLE_PYTHON
PYTHON_DIR = plugin-python
endif
+if ENABLE_ONLINE_ACCOUNTS
+ONLINE_ACCOUNTS_DIR = online-accounts
+endif
+
if ENABLE_NETWORK_MANAGER
NETWORK_MANAGER_DIR = network-manager
endif
@@ -30,6 +34,7 @@ SUBDIRS = \
startup-wizard \
$(MONO_DIR) \
$(PYTHON_DIR) \
+ $(ONLINE_ACCOUNTS_DIR) \
$(NETWORK_MANAGER_DIR) \
$(WINDOWS_SENS_DIR) \
$(CONNMAN_DIR)