aboutsummaryrefslogtreecommitdiffstats
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorFridrich Strba <fridrich.strba@bluewin.ch>2010-03-24 01:54:37 +0800
committerFridrich Štrba <fridrich.strba@bluewin.ch>2010-04-08 05:44:16 +0800
commitd358da9481a125e7eefa80cde88a6bed0c1b7fc3 (patch)
tree845e49c13ded6fcc88dbad9cbd387ff8b4ebd413 /modules/Makefile.am
parentcd7fadfcdbbf983dbee379d55bd8a6e44351e8fa (diff)
downloadgsoc2013-evolution-d358da9481a125e7eefa80cde88a6bed0c1b7fc3.tar
gsoc2013-evolution-d358da9481a125e7eefa80cde88a6bed0c1b7fc3.tar.gz
gsoc2013-evolution-d358da9481a125e7eefa80cde88a6bed0c1b7fc3.tar.bz2
gsoc2013-evolution-d358da9481a125e7eefa80cde88a6bed0c1b7fc3.tar.lz
gsoc2013-evolution-d358da9481a125e7eefa80cde88a6bed0c1b7fc3.tar.xz
gsoc2013-evolution-d358da9481a125e7eefa80cde88a6bed0c1b7fc3.tar.zst
gsoc2013-evolution-d358da9481a125e7eefa80cde88a6bed0c1b7fc3.zip
[win32] Implement network status detection
The implementation is done using System Event Notification Service by implementing ConnectionMade ConnectionMadeNoQOCInfo and ConnectionLost methods of ISensNetwork interface. Make the subscription to the network status notification receive the event only if the ownerof the subscription is logged on to the same computer as the publisher. This makes this module work on Windows Vista and Windows 7 with normal user account. Don't try to build Windows SENS when not building for Windows. Extract the relevant COM structs and typedefs from mingw-w64 headers to allow to build the module with mingw.org toolchain and fix build breakages with Microsoft compilers.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 0b6ccf22ec..653d1b69c6 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -10,6 +10,10 @@ if ENABLE_NETWORK_MANAGER
NETWORK_MANAGER_DIR = network-manager
endif
+if ENABLE_WINDOWS_SENS
+WINDOWS_SENS_DIR = windows-sens
+endif
+
SUBDIRS = \
addressbook \
calendar \
@@ -17,6 +21,7 @@ SUBDIRS = \
plugin-lib \
$(MONO_DIR) \
$(PYTHON_DIR) \
- $(NETWORK_MANAGER_DIR)
+ $(NETWORK_MANAGER_DIR) \
+ $(WINDOWS_SENS_DIR)
-include $(top_srcdir)/git.mk