aboutsummaryrefslogtreecommitdiffstats
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-03-20 23:38:33 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-03-20 23:49:46 +0800
commit6c569e64af88867f2a0007f1fb047a00fb8f9ef0 (patch)
treeff1cc1273830b0d14b2c76b91b2bfdbf3cc54d87 /modules/Makefile.am
parent185b7b2a0b5641bdfafd440568d11c4521c42573 (diff)
downloadgsoc2013-evolution-6c569e64af88867f2a0007f1fb047a00fb8f9ef0.tar
gsoc2013-evolution-6c569e64af88867f2a0007f1fb047a00fb8f9ef0.tar.gz
gsoc2013-evolution-6c569e64af88867f2a0007f1fb047a00fb8f9ef0.tar.bz2
gsoc2013-evolution-6c569e64af88867f2a0007f1fb047a00fb8f9ef0.tar.lz
gsoc2013-evolution-6c569e64af88867f2a0007f1fb047a00fb8f9ef0.tar.xz
gsoc2013-evolution-6c569e64af88867f2a0007f1fb047a00fb8f9ef0.tar.zst
gsoc2013-evolution-6c569e64af88867f2a0007f1fb047a00fb8f9ef0.zip
Convert NetworkManager integration to an EShell extension.
This demonstrates how to extend EShell without having to modify and recompile e-shell.c. If NetworkManager integration is enabled, the extension is loaded automatically when the EShell is created. The same pattern can be applied to integrate other network monitoring software like ConnMan or Microsoft's Wireless Zero Configuration.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index f792a4d9ee..0b6ccf22ec 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -6,6 +6,17 @@ if ENABLE_PYTHON
PYTHON_DIR = plugin-python
endif
-SUBDIRS = addressbook calendar mail plugin-lib $(MONO_DIR) $(PYTHON_DIR)
+if ENABLE_NETWORK_MANAGER
+NETWORK_MANAGER_DIR = network-manager
+endif
+
+SUBDIRS = \
+ addressbook \
+ calendar \
+ mail \
+ plugin-lib \
+ $(MONO_DIR) \
+ $(PYTHON_DIR) \
+ $(NETWORK_MANAGER_DIR)
-include $(top_srcdir)/git.mk