aboutsummaryrefslogtreecommitdiffstats
path: root/modules/Makefile.am
diff options
context:
space:
mode:
authorDan Vrátil <dvratil@redhat.com>2012-10-09 05:27:29 +0800
committerDan Vrátil <dvratil@redhat.com>2012-10-09 05:27:29 +0800
commit5437fa7c354b5ddf12b4e13136834d86168e3580 (patch)
tree30f8236f3ce563a40aeadfdbb3eb18b90b2f219c /modules/Makefile.am
parent1cfe0327ca436a687383412664e3a5c2869c7dda (diff)
downloadgsoc2013-evolution-5437fa7c354b5ddf12b4e13136834d86168e3580.tar
gsoc2013-evolution-5437fa7c354b5ddf12b4e13136834d86168e3580.tar.gz
gsoc2013-evolution-5437fa7c354b5ddf12b4e13136834d86168e3580.tar.bz2
gsoc2013-evolution-5437fa7c354b5ddf12b4e13136834d86168e3580.tar.lz
gsoc2013-evolution-5437fa7c354b5ddf12b4e13136834d86168e3580.tar.xz
gsoc2013-evolution-5437fa7c354b5ddf12b4e13136834d86168e3580.tar.zst
gsoc2013-evolution-5437fa7c354b5ddf12b4e13136834d86168e3580.zip
Bug #684447 - Check for highlight during configure.
If the highlight program cannot be found width AC_PATH_PROGS, configure will abort with an error message. You can either a) install highlight b) specify the patch with HIGHLIGHT=/path/to/highlight c) pass --disable-text-highlight to configure to exclude the module This also makes text-highlight module to fallback to text/plain formatter when highlight program would crash or fail to ensure the content is delivered to user.
Diffstat (limited to 'modules/Makefile.am')
-rw-r--r--modules/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/modules/Makefile.am b/modules/Makefile.am
index a7e34de52b..6bb19c8071 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -26,6 +26,10 @@ if ENABLE_AUDIO_INLINE
AUDIO_INLINE_DIR = audio-inline
endif
+if ENABLE_TEXT_HIGHLIGHT
+TEXT_HIGHLIGHT_DIR = text-highlight
+endif
+
SUBDIRS = \
addressbook \
calendar \
@@ -52,13 +56,13 @@ SUBDIRS = \
plugin-manager \
prefer-plain \
startup-wizard \
- text-highlight \
vcard-inline \
web-inspector \
$(BOGOFILTER_DIR) \
$(ONLINE_ACCOUNTS_DIR) \
$(SPAMASSASSIN_DIR) \
$(TNEF_ATTACHMENT_DIR) \
- $(AUDIO_INLINE_DIR)
+ $(AUDIO_INLINE_DIR) \
+ $(TEXT_HIGHLIGHT_DIR)
-include $(top_srcdir)/git.mk