aboutsummaryrefslogtreecommitdiffstats
path: root/mail/importers/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-06-25 00:59:33 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-06-25 06:29:22 +0800
commitf0d3f3afdfa314e1e8cd7d8da790878008a46aad (patch)
tree7116e2a18c7bd50633b2f8de42b5377af1e8172a /mail/importers/Makefile.am
parent94302ea73cde0b470faad653f752406f19f202d7 (diff)
downloadgsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.gz
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.bz2
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.lz
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.xz
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.tar.zst
gsoc2013-evolution-f0d3f3afdfa314e1e8cd7d8da790878008a46aad.zip
Radically reorganize source code.
- Collect all shell modules into a new top-level 'modules' directory: $(top_srcdir)/modules/addressbook $(top_srcdir)/modules/calendar $(top_srcdir)/modules/mail Nothing is allowed to link to these, not plugins nor other modules. THIS SOLVES BUG #571275 AND OPENS THE DOOR TO PORTING TO MAC OS X. - Mimic the libevolution-mail-shared library from master (except drop the "shared" suffix) and have libevolution-mail-importers and all mail-related plugins link to it. - Discard the a11y subdirectories and have the files live alongside their counterpart widgets.
Diffstat (limited to 'mail/importers/Makefile.am')
-rw-r--r--mail/importers/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/mail/importers/Makefile.am b/mail/importers/Makefile.am
new file mode 100644
index 0000000000..ecd883cd8b
--- /dev/null
+++ b/mail/importers/Makefile.am
@@ -0,0 +1,33 @@
+if OS_WIN32
+WIN32_BOOTSTRAP_LIBS = \
+ $(top_builddir)/win32/libevolution-mail.la
+endif
+
+privsolib_LTLIBRARIES = libevolution-mail-importers.la
+
+INCLUDES = -I.. \
+ -I$(srcdir)/.. \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/widgets \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ -DG_LOG_DOMAIN=\"evolution-mail-importer\" \
+ -DEVOLUTION_PRIVDATADIR=\""$(privdatadir)"\" \
+ $(IMPORTERS_CFLAGS)
+
+libevolution_mail_importers_la_SOURCES = \
+ mail-importer.c \
+ mail-importer.h \
+ elm-importer.c \
+ pine-importer.c \
+ evolution-mbox-importer.c
+
+libevolution_mail_importers_la_LDFLAGS = $(NO_UNDEFINED)
+
+libevolution_mail_importers_la_LIBADD = \
+ $(WIN32_BOOTSTRAP_LIBS) \
+ $(top_builddir)/e-util/libeutil.la \
+ $(top_builddir)/filter/libfilter.la \
+ $(top_builddir)/mail/libevolution-mail.la \
+ $(IMPORTERS_LIBS)
+
+-include $(top_srcdir)/git.mk