aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2009-05-20 22:50:00 +0800
committerMilan Crha <mcrha@redhat.com>2009-05-20 22:50:00 +0800
commitf4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81 (patch)
tree1c0228db536f5fa0efc6e0f779bb86df610989d0 /mail/Makefile.am
parent3acc45b10c9849aa5385a762b4d139472916dca1 (diff)
downloadgsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.gz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.bz2
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.lz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.xz
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.tar.zst
gsoc2013-evolution-f4cf9af33ccde3142a3011e8b2dbcfb4cbc9ae81.zip
Use -no-undefined on Linux too
There still left two things opened, search for KILL-BONOBO to find them. One is in calendar's Makefile.am, one in composer.
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am17
1 files changed, 8 insertions, 9 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 11ee7f5edc..56a946480b 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -1,4 +1,4 @@
-SUBDIRS = default importers
+SUBDIRS = default
mailincludedir = $(privincludedir)/mail
@@ -7,6 +7,7 @@ INCLUDES = \
-I$(top_srcdir)/widgets/e-text \
-I$(top_srcdir)/widgets/misc \
-I$(top_srcdir) \
+ -I$(top_srcdir)/em-format \
-I$(top_srcdir)/mail \
-I$(top_srcdir)/composer \
-I$(top_builddir)/composer \
@@ -112,8 +113,6 @@ libevolution_module_mail_la_SOURCES = \
em-folder-tree-model.h \
em-folder-utils.c \
em-folder-utils.h \
- em-format.c \
- em-format.h \
em-format-hook.c \
em-format-hook.h \
em-format-html.c \
@@ -122,8 +121,6 @@ libevolution_module_mail_la_SOURCES = \
em-format-html-display.h \
em-format-html-print.c \
em-format-html-print.h \
- em-format-quote.c \
- em-format-quote.h \
em-html-stream.c \
em-html-stream.h \
em-icon-stream.c \
@@ -142,8 +139,6 @@ libevolution_module_mail_la_SOURCES = \
em-popup.h \
em-search-context.c \
em-search-context.h \
- em-stripsig-filter.c \
- em-stripsig-filter.h \
em-subscribe-editor.c \
em-subscribe-editor.h \
em-sync-stream.c \
@@ -179,7 +174,12 @@ libevolution_module_mail_la_SOURCES = \
message-tag-editor.c \
message-tag-editor.h \
message-tag-followup.c \
- message-tag-followup,h
+ message-tag-followup.h \
+ importers/mail-importer.c \
+ importers/mail-importer.h \
+ importers/elm-importer.c \
+ importers/pine-importer.c \
+ importers/evolution-mbox-importer.c
libevolution_module_mail_la_LIBADD = \
$(top_builddir)/e-util/libeutil.la \
@@ -188,7 +188,6 @@ libevolution_module_mail_la_LIBADD = \
$(top_builddir)/widgets/table/libetable.la \
$(top_builddir)/widgets/text/libetext.la \
$(top_builddir)/widgets/misc/libemiscwidgets.la \
- $(top_builddir)/mail/importers/libevolution-mail-importers.la \
$(top_builddir)/addressbook/gui/contact-editor/libecontacteditor.la \
$(top_builddir)/addressbook/gui/contact-list-editor/libecontactlisteditor.la \
$(SMIME_LIBS)