aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:11:58 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-01-23 04:11:58 +0800
commitcd8eae592e7ad9c2a2bbf34892a5ffb941a7db57 (patch)
treec2a4b76233b03ca155b9aeb223df68edf56d1910 /mail/Makefile.am
parent61300d7b247a126e2370e11075589fec81349ae7 (diff)
downloadgsoc2013-evolution-cd8eae592e7ad9c2a2bbf34892a5ffb941a7db57.tar
gsoc2013-evolution-cd8eae592e7ad9c2a2bbf34892a5ffb941a7db57.tar.gz
gsoc2013-evolution-cd8eae592e7ad9c2a2bbf34892a5ffb941a7db57.tar.bz2
gsoc2013-evolution-cd8eae592e7ad9c2a2bbf34892a5ffb941a7db57.tar.lz
gsoc2013-evolution-cd8eae592e7ad9c2a2bbf34892a5ffb941a7db57.tar.xz
gsoc2013-evolution-cd8eae592e7ad9c2a2bbf34892a5ffb941a7db57.tar.zst
gsoc2013-evolution-cd8eae592e7ad9c2a2bbf34892a5ffb941a7db57.zip
Use EVOLUTION_GALVIEWSDIR.
* folder-browser-ui.c (folder_browser_ui_setup_view_menus): Use EVOLUTION_GALVIEWSDIR. * message-browser.c (set_bonobo_ui): Get evolution-mail-messagedisplay.xml from EVOLUTION_UIDIR. * mail-signature-editor.c (mail_signature_editor): Get evolution-signature-editor.xml from EVOLUTION_UIDIR. * folder-browser-ui.c (ui_add): Get the evoluiton-mail* XML files from EVOLUTION_UIDIR. * Makefile.am (INCLUDES): Define EVOLUTION_GALVIEWSDIR; update EVOLUTION_IMAGESDIR to include the $(BASE_VERSION). (gladedir): Version using $(BASE_VERSION). (etspecdir): Likewise. (iconsdir): Likewise. (buttonsdir): Likewise. (etspecdir): Likewise. * component-factory.c (owner_set_cb): Look for vfoldertypes.xml in the new version-aware location. * mail-summary.c (generate_folder_summaries): Likewise. * mail-search-dialogue.c (mail_search_dialogue_construct): Likewise. * mail-vfolder.c (vfolder_load_storage): Likewise. * mail-autofilter.c (filter_gui_add_from_message): Look for filtertypes.xml in the new version-aware location. (mail_filter_rename_uri): Likewise. (mail_filter_delete_uri): Likewise. * mail-session.c (main_get_filter_driver): Likewise. * mail-callbacks.c (filter_edit): Likewise. svn path=/trunk/; revision=19562
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am62
1 files changed, 32 insertions, 30 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index d1a9ee819d..a6f01cedb5 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -6,32 +6,34 @@ SUBDIRS = importers
importerdir = $(privlibdir)/evolution-mail-importers
-INCLUDES = \
- -I$(top_srcdir)/widgets \
- -I$(top_srcdir)/widgets/e-text \
- -I$(top_srcdir)/widgets/misc \
- -I$(top_srcdir)/camel \
- -I$(top_srcdir) \
- -I$(top_srcdir)/composer \
- -I$(top_builddir)/composer \
- -I$(top_builddir)/shell \
- -I$(top_srcdir)/shell \
- -I$(top_srcdir)/shell/importer \
- -I$(top_builddir)/shell/importer \
- -I$(top_srcdir)/addressbook/backend \
- -I$(top_builddir)/addressbook/backend \
- $(EVOLUTION_MAIL_CFLAGS) \
- -DEVOLUTION_DATADIR=\""$(datadir)"\" \
- -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
- -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
- -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
- -DEVOLUTION_IMAGES=\""$(datadir)/evolution/images"\" \
- -DEVOLUTION_BUTTONSDIR=\""$(buttonsdir)"\" \
- -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
- -DCAMEL_PROVIDERDIR=\""$(camel_providerdir)"\" \
- -DMAIL_IMPORTERSDIR=\""$(importerdir)"\" \
- -DG_DISABLE_DEPRECATED \
- -DGTK_DISABLE_DEPRECATED \
+INCLUDES = \
+ -I$(top_srcdir)/widgets \
+ -I$(top_srcdir)/widgets/e-text \
+ -I$(top_srcdir)/widgets/misc \
+ -I$(top_srcdir)/camel \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/composer \
+ -I$(top_builddir)/composer \
+ -I$(top_builddir)/shell \
+ -I$(top_srcdir)/shell \
+ -I$(top_srcdir)/shell/importer \
+ -I$(top_builddir)/shell/importer \
+ -I$(top_srcdir)/addressbook/backend \
+ -I$(top_builddir)/addressbook/backend \
+ $(EVOLUTION_MAIL_CFLAGS) \
+ -DEVOLUTION_DATADIR=\""$(datadir)"\" \
+ -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" \
+ -DEVOLUTION_ETSPECDIR=\""$(etspecdir)"\" \
+ -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" \
+ -DEVOLUTION_IMAGES=\""$(datadir)"/evolution-$(BASE_VERSION)/images\" \
+ -DEVOLUTION_GALVIEWSDIR=\"$(datadir)/evolution-$(BASE_VERSION)/views\" \
+ -DEVOLUTION_BUTTONSDIR=\""$(buttonsdir)"\" \
+ -DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
+ -DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
+ -DCAMEL_PROVIDERDIR=\""$(camel_providerdir)"\" \
+ -DMAIL_IMPORTERSDIR=\""$(importerdir)"\" \
+ -DG_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
-DG_LOG_DOMAIN=\"evolution-mail\"
componentdir = $(COMPONENT_DIR)
@@ -176,17 +178,17 @@ $(server_in_files:.server.in.in=.server.in): $(server_in_files)
sed -e "s|\@COMPONENTDIR\@|$(componentdir)|" $< > $@
@INTLTOOL_SERVER_RULE@
-gladedir = $(datadir)/evolution/glade
+gladedir = $(datadir)/evolution-$(BASE_VERSION)/glade
glade_DATA = mail-config.glade local-config.glade subscribe-dialog.glade message-tags.glade
-etspecdir = $(datadir)/evolution/etspec/
+etspecdir = $(datadir)/evolution-$(BASE_VERSION)/etspec/
etspec_DATA = mail-accounts.etspec message-list.etspec subscribe-dialog.etspec
schemadir = $(GCONF_SCHEMA_FILE_DIR)
schema_DATA = evolution-mail.schemas
-iconsdir = $(datadir)/evolution/images
-buttonsdir = $(datadir)/evolution/images/buttons
+iconsdir = $(datadir)/evolution-$(BASE_VERSION)/images
+buttonsdir = $(datadir)/evolution-$(BASE_VERSION)/images/buttons
idl_DATA = Mailer.idl