aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2001-06-03 15:41:05 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2001-06-03 15:41:05 +0800
commitb8306eaf97e4f85b087e4c30a1f3793490d08a01 (patch)
tree733692e0e02b03ea28ad836cd897f45558695783 /mail/Makefile.am
parent907d3f8a5467ac3891e8734b436b5ab6046e0e6e (diff)
downloadgsoc2013-evolution-b8306eaf97e4f85b087e4c30a1f3793490d08a01.tar
gsoc2013-evolution-b8306eaf97e4f85b087e4c30a1f3793490d08a01.tar.gz
gsoc2013-evolution-b8306eaf97e4f85b087e4c30a1f3793490d08a01.tar.bz2
gsoc2013-evolution-b8306eaf97e4f85b087e4c30a1f3793490d08a01.tar.lz
gsoc2013-evolution-b8306eaf97e4f85b087e4c30a1f3793490d08a01.tar.xz
gsoc2013-evolution-b8306eaf97e4f85b087e4c30a1f3793490d08a01.tar.zst
gsoc2013-evolution-b8306eaf97e4f85b087e4c30a1f3793490d08a01.zip
Fix linking order for `$(DB3_LDADD)'s so that we avoid pulling
functions from a different Berkeley DB library when we really don't mean to. svn path=/trunk/; revision=10105
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index aae0804394..f3931514ea 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -102,11 +102,12 @@ evolution_mail_SOURCES = \
mail.h
evolution_mail_LDADD = \
+ $(top_builddir)/camel/libcamel.la \
+ $(DB3_LDADD) \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/shell/libeshell.la \
$(top_builddir)/composer/libcomposer.a \
$(top_builddir)/widgets/misc/libemiscwidgets.a \
- $(top_builddir)/camel/libcamel.la \
$(top_builddir)/addressbook/backend/ebook/libebook.la \
$(top_builddir)/libversit/libversit.la \
$(top_builddir)/e-util/ename/libename.la \
@@ -115,8 +116,7 @@ evolution_mail_LDADD = \
$(top_builddir)/executive-summary/evolution-services/libevolution-services.la \
$(top_builddir)/shell/importer/libevolution-importer.la \
$(top_builddir)/widgets/menus/libmenus.la \
- $(MAILER_LIBS) \
- $(DB3_LDADD)
+ $(MAILER_LIBS)
evolution_mail_LDFLAGS = \
-export-dynamic