aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2004-05-12 11:34:33 +0800
committerMichael Zucci <zucchi@src.gnome.org>2004-05-12 11:34:33 +0800
commit97926d706a599a789b8d7b03a9e41a20513659d1 (patch)
tree89f1c9d163e295ebb436a53de2dcd506c81ba3e4 /mail/Makefile.am
parent2cf63ca4bace1165d5f0385f4d0dbcce83269775 (diff)
downloadgsoc2013-evolution-97926d706a599a789b8d7b03a9e41a20513659d1.tar
gsoc2013-evolution-97926d706a599a789b8d7b03a9e41a20513659d1.tar.gz
gsoc2013-evolution-97926d706a599a789b8d7b03a9e41a20513659d1.tar.bz2
gsoc2013-evolution-97926d706a599a789b8d7b03a9e41a20513659d1.tar.lz
gsoc2013-evolution-97926d706a599a789b8d7b03a9e41a20513659d1.tar.xz
gsoc2013-evolution-97926d706a599a789b8d7b03a9e41a20513659d1.tar.zst
gsoc2013-evolution-97926d706a599a789b8d7b03a9e41a20513659d1.zip
add for translators.
2004-05-12 Not Zed <NotZed@Ximian.com> * mail-errors.xml.h: add for translators. * Makefile.am (%.xml.h): fix for xml i18n stuff. * mail-errors.xml: moved from the .xml.in file. 2004-05-11 Not Zed <NotZed@Ximian.com> * em-utils.c (em_uri_from_camel): pass an exception to provider_get, it relies on one. * em-migrate.c (em_migrate_1_4): fix some error messages, and fail with fatal errors properly. (em_migrate_local_folders_1_4): EEP! Who cares if this fails! Well I do. Setup exceptions and return codes. (em_migrate_dir): and here too. Sloppy! (em_migrate_dir): change the code slightly, 1.4 would recurse all folders, even if the parent folder doesn't have a folder-metadata.xml. Make sure we copy that mode. (get_local_store_uri): Make it copy the 1.4 behaviour properly. Any error -> use defaults. (em_migrate_dir): lots of changes. (mbox_build_filename): take the output string as an arg. (cp): add an argument to overwrite/append or require a unique empty file. (cp_r): add mode arg here too. (em_migrate_folder): split the folder copy stuff from em_migrate dir entirely. blah. (em_upgrade_accounts_1_4): can't fail, remove return code, etc. (em_upgrade_xml_1_4): removed this rather redundant odd api. (upgrade_xml_uris): this can't fail, remove return codes etc. (em_upgrade_xml_1_0): another oddly redundant function. (em_migrate_pop_uid_caches_1_4): error messages, blah blah. (em_migrate_folder_expand_state_1_4): no fatal states here. (em_migrate_folder_view_settings_1_4): nor here. (emm_setup_initial): do i18n 'better', using gnome_i18n_get_language_list, rather than hacky code. 2004-05-10 Not Zed <NotZed@Ximian.com> * mail-tools.c: remove e-meta.h, not used anymore. svn path=/trunk/; revision=25870
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index c8b533bd26..6d9f0c7f73 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -184,10 +184,11 @@ server_DATA = $(server_in_files:.server.in.in=_$(BASE_VERSION).server)
# Misc data to install
-error_in_files = mail-errors.xml.in
-error_DATA = $(error_in_files:.xml.in=.xml)
+error_DATA = mail-errors.xml
+error_i18n = $(error_DATA:.xml=.xml.h)
errordir = $(privdatadir)/errors
-@INTLTOOL_XML_RULE@
+%.xml.h: %.xml
+ $(top_builddir)/e-util/e-error-tool $^
glade_DATA = mail-config.glade subscribe-dialog.glade message-tags.glade mail-search.glade mail-security.glade
MARSHAL_GENERATED = em-marshal.c em-marshal.h
@@ -199,7 +200,7 @@ EXTRA_DIST = \
ChangeLog.pre-1-4 \
em-marshal.list \
$(SPELL_IDL) \
- $(error_in_files) \
+ $(error_DATA) $(error_i18n) \
$(glade_DATA) \
$(schema_DATA) \
$(server_in_files) \
@@ -243,6 +244,6 @@ install-data-local:
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
-BUILT_SOURCES = $(SPELL_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(error_DATA)
+BUILT_SOURCES = $(SPELL_IDL_GENERATED) $(MARSHAL_GENERATED) $(server_DATA) $(error_i18n)
CLEANFILES = $(BUILT_SOURCES)