aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2002-12-17 00:47:51 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2002-12-17 00:47:51 +0800
commit2f1a1a22feb83e27635bb25658ae6b4103285878 (patch)
treecd8f956f8ba6f401e00fd9b1c9623844d5cec8dd /mail/Makefile.am
parent8740d35feedeeae19b137a723a2d2fac5cae5fa5 (diff)
downloadgsoc2013-evolution-2f1a1a22feb83e27635bb25658ae6b4103285878.tar
gsoc2013-evolution-2f1a1a22feb83e27635bb25658ae6b4103285878.tar.gz
gsoc2013-evolution-2f1a1a22feb83e27635bb25658ae6b4103285878.tar.bz2
gsoc2013-evolution-2f1a1a22feb83e27635bb25658ae6b4103285878.tar.lz
gsoc2013-evolution-2f1a1a22feb83e27635bb25658ae6b4103285878.tar.xz
gsoc2013-evolution-2f1a1a22feb83e27635bb25658ae6b4103285878.tar.zst
gsoc2013-evolution-2f1a1a22feb83e27635bb25658ae6b4103285878.zip
Re-implemented to use streams. Also no need to check for html since
2002-12-16 Jeffrey Stedfast <fejj@ximian.com> * mail-format.c (handle_text_plain): Re-implemented to use streams. Also no need to check for html since camel-mime-part-utils.c now does this for us and will re-tag the mime-type as text/html thus the UI can be completely ignorant of this process. (handle_text_plain_flowed): Removed. (write_one_text_plain_chunk): Removed. (try_uudecoding): Removed. (try_inline_binhex): Removed. (handle_text_enriched): Re-implemented to use streams too. 2002-12-15 Jeffrey Stedfast <fejj@ximian.com> * mail-format.c (write_text_header): Change the order of the args to be consistant with other write functions. (write_date): Same. (write_field_row_begin): Here too. (write_headers): Here too. (write_one_text_plain_chunk): Don't strdup just to pass it to mail_text_write() so that it can dup it yet again into html text and dup it yet a 3rd time into a GByteArray. Instead just write it to gtkhtml. (handle_*): Fixed arguments to take a MailDisplayStream instead of a GtkHTML widget and a GtkHMLStream. * mail-display.c (mail_display_render): Create a MailDisplayStream to pass to mail_format_mime_message() and mail_format_raw_message(). * mail-display-stream.[c,h]: New stream to replace mail-stream-gtkhtml.c * mail-stream-gtkhtml.[c,h]: Removed. svn path=/trunk/; revision=19126
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index b1f5864174..c819ad4310 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -90,6 +90,8 @@ evolution_mail_SOURCES = \
mail-preferences.h \
mail-display.c \
mail-display.h \
+ mail-display-stream.c \
+ mail-display-stream.h \
mail-folder-cache.c \
mail-folder-cache.h \
mail-format.c \
@@ -114,8 +116,6 @@ evolution_mail_SOURCES = \
mail-session.h \
mail-signature-editor.c \
mail-signature-editor.h \
- mail-stream-gtkhtml.c \
- mail-stream-gtkhtml.h \
mail-tools.c \
mail-tools.h \
mail-types.h \