aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorEttore Perazzoli <ettore@src.gnome.org>2003-02-11 01:39:10 +0800
committerEttore Perazzoli <ettore@src.gnome.org>2003-02-11 01:39:10 +0800
commit24d00dba858a3a5c87092a3ac6c837c456cf4ca8 (patch)
tree3f88196ae086e6a0fc1bcbcf81a398a588b1fc68 /mail/Makefile.am
parent29fb1732b2f2d50bc6bba812394621dc5df27fda (diff)
downloadgsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.gz
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.bz2
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.lz
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.xz
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.tar.zst
gsoc2013-evolution-24d00dba858a3a5c87092a3ac6c837c456cf4ca8.zip
Split the ORBit IDL compilation rules to work properly with parallel
* importers/Makefile.am: Split the ORBit IDL compilation rules to work properly with parallel makes. (BUILT_SOURCES): Add this. (CLEANFILES): Add this. * Makefile.am: Split the ORBit IDL compilation rules to work properly with parallel makes. (BUILT_SOURCES): Add $(IDL_GENERATED) here. (CLEANFILES): Remove from here. svn path=/trunk/; revision=19874
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am26
1 files changed, 16 insertions, 10 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 1da0cd5fb8..a7d2d36f02 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -39,22 +39,27 @@ INCLUDES = \
component_LTLIBRARIES = libevolution-mail.la
-EVOLUTION_MAIL_CORBA_GENERATED = \
- Mailer.h \
- Mailer-common.c \
- Mailer-skels.c \
+EVOLUTION_MAIL_CORBA_GENERATED_H = \
+ Mailer.h
+EVOLUTION_MAIL_CORBA_GENERATED_C = \
+ Mailer-common.c \
+ Mailer-skels.c \
Mailer-stubs.c
+EVOLUTION_MAIL_CORBA_GENERATED = $(EVOLUTION_MAIL_CORBA_GENERATED_C) $(EVOLUTION_MAIL_CORBA_GENERATED_H)
SPELL_IDL = Spell.idl
-IDL_GENERATED = \
- Spell.h \
+IDL_GENERATED_H = \
+ Spell.h
+IDL_GENERATED_C = \
Spell-common.c \
Spell-skels.c \
Spell-stubs.c
+IDL_GENERATED = $(IDL_GENERATED_C) $(IDL_GENERATED_H)
-$(IDL_GENERATED): $(SPELL_IDL)
+$(IDL_GENERATED_H): $(SPELL_IDL)
$(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl $(IDL_INCLUDES) $(srcdir)/Spell.idl
+$(IDL_GENERATED_C): $(IDL_GENERATED_H)
Spell-impl.o: Spell.h
@@ -186,8 +191,9 @@ schema_DATA = evolution-mail.schemas
idl_DATA = Mailer.idl
-$(EVOLUTION_MAIL_CORBA_GENERATED): Mailer.idl
+$(EVOLUTION_MAIL_CORBA_GENERATED_H): Mailer.idl
$(ORBIT_IDL) -I $(srcdir) -I $(datadir)/idl $(IDL_INCLUDES) $(srcdir)/Mailer.idl
+$(EVOLUTION_MAIL_CORBA_GENERATED_C): $(EVOLUTION_MAIL_CORBA_GENERATED_H)
EXTRA_DIST = \
Mailer.idl \
@@ -219,5 +225,5 @@ endif
dist-hook:
cd $(distdir); rm -f $(BUILT_SOURCES)
-BUILT_SOURCES = $(EVOLUTION_MAIL_CORBA_GENERATED)
-CLEANFILES = $(BUILT_SOURCES) $(IDL_GENERATED)
+BUILT_SOURCES = $(EVOLUTION_MAIL_CORBA_GENERATED) $(IDL_GENERATED)
+CLEANFILES = $(BUILT_SOURCES)