aboutsummaryrefslogtreecommitdiffstats
path: root/mail/Makefile.am
diff options
context:
space:
mode:
authorNot Zed <NotZed@Ximian.com>2004-02-11 16:26:58 +0800
committerMichael Zucci <zucchi@src.gnome.org>2004-02-11 16:26:58 +0800
commit06b08adb257351bf8080d960fb98b4265cc43081 (patch)
tree9f429f497d47c5b933d2c4c98a1058566233a7dc /mail/Makefile.am
parent136b8ea938580f3c1d4fb9f92093c4631ec6038b (diff)
downloadgsoc2013-evolution-06b08adb257351bf8080d960fb98b4265cc43081.tar
gsoc2013-evolution-06b08adb257351bf8080d960fb98b4265cc43081.tar.gz
gsoc2013-evolution-06b08adb257351bf8080d960fb98b4265cc43081.tar.bz2
gsoc2013-evolution-06b08adb257351bf8080d960fb98b4265cc43081.tar.lz
gsoc2013-evolution-06b08adb257351bf8080d960fb98b4265cc43081.tar.xz
gsoc2013-evolution-06b08adb257351bf8080d960fb98b4265cc43081.tar.zst
gsoc2013-evolution-06b08adb257351bf8080d960fb98b4265cc43081.zip
Basically rewrote this, the import tasks run in another thread. It tells
2004-02-11 Not Zed <NotZed@Ximian.com> * importers/pine-importer.c: Basically rewrote this, the import tasks run in another thread. It tells you more about what's going on, and its cancellable. (pine_store_settings): changed the meaning of the settings slightly, if set it means we've processed them already. * mail-component-factory.c (factory): hook in importer factory callback. 2004-02-10 Not Zed <NotZed@Ximian.com> * importers/*-importer.c: removed module init, just provide a new method. Updates for api changes. * Makefile.am: link mail importers in directly. * mail-importer.c: changed to do stuff in-memory with linked stuff, moved to importers/. * importers/GNOME_Evolution_Mail_Importers.server.in.in: merge all importer .server info's here, point them all to the mailer factory. Removed the others. * importers/Makefile.am: remove Mailer.idl stuff. Move all importers to a single library. svn path=/trunk/; revision=24701
Diffstat (limited to 'mail/Makefile.am')
-rw-r--r--mail/Makefile.am12
1 files changed, 2 insertions, 10 deletions
diff --git a/mail/Makefile.am b/mail/Makefile.am
index 97a9b33498..4dd75db8d8 100644
--- a/mail/Makefile.am
+++ b/mail/Makefile.am
@@ -1,6 +1,4 @@
-SUBDIRS = default # importers FIXME
-
-importerdir = $(privlibdir)/evolution-mail-importers
+SUBDIRS = default importers
INCLUDES = \
-I$(top_srcdir)/widgets \
@@ -29,7 +27,6 @@ INCLUDES = \
-DEVOLUTION_LOCALEDIR=\""$(localedir)"\" \
-DEVOLUTION_UIDIR=\""$(evolutionuidir)"\" \
-DCAMEL_PROVIDERDIR=\""$(camel_providerdir)"\" \
- -DMAIL_IMPORTERSDIR=\""$(importerdir)"\" \
-DPREFIX=\""$(prefix)"\" \
-DG_LOG_DOMAIN=\"evolution-mail\"
@@ -163,13 +160,9 @@ libevolution_mail_la_SOURCES = \
message-tag-followup.h \
mail.h
-# EPFIXME: Functionality to be brought back to life.
-#
-# mail-local.c
-# mail-local.h
-
libevolution_mail_la_LIBADD = \
$(top_builddir)/shell/importer/libevolution-importer.la \
+ $(top_builddir)/mail/importers/libevolution-mail-importers.la\
$(top_builddir)/camel/libcamel.la \
$(top_builddir)/e-util/libeutil.la \
$(top_builddir)/shell/libeshell.la \
@@ -183,7 +176,6 @@ libevolution_mail_la_LIBADD = \
libevolution_mail_la_LDFLAGS = \
-avoid-version -module
-
# .server files
server_in_files = GNOME_Evolution_Mail.server.in.in