aboutsummaryrefslogtreecommitdiffstats
path: root/libgnomecanvas/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2010-06-14 06:37:27 +0800
committerMatthew Barnes <mbarnes@redhat.com>2010-06-14 09:31:58 +0800
commite6972011f01eab9f8d0a4584f32ee1e2a00f3231 (patch)
tree69e2a5e846965c3b369724b825f5b35c6d88056a /libgnomecanvas/Makefile.am
parent7f3377c78a560aa762e04d596b79f847c4acd870 (diff)
downloadgsoc2013-evolution-e6972011f01eab9f8d0a4584f32ee1e2a00f3231.tar
gsoc2013-evolution-e6972011f01eab9f8d0a4584f32ee1e2a00f3231.tar.gz
gsoc2013-evolution-e6972011f01eab9f8d0a4584f32ee1e2a00f3231.tar.bz2
gsoc2013-evolution-e6972011f01eab9f8d0a4584f32ee1e2a00f3231.tar.lz
gsoc2013-evolution-e6972011f01eab9f8d0a4584f32ee1e2a00f3231.tar.xz
gsoc2013-evolution-e6972011f01eab9f8d0a4584f32ee1e2a00f3231.tar.zst
gsoc2013-evolution-e6972011f01eab9f8d0a4584f32ee1e2a00f3231.zip
Embed libart_lgpl and libgnomecanvas.
Both of these modules are deprecated and going away in GNOME 3 but we still rely heavily on them for GnomeCalendar and ETable. So, welcome to the island of unwanted libraries...
Diffstat (limited to 'libgnomecanvas/Makefile.am')
-rw-r--r--libgnomecanvas/Makefile.am83
1 files changed, 83 insertions, 0 deletions
diff --git a/libgnomecanvas/Makefile.am b/libgnomecanvas/Makefile.am
new file mode 100644
index 0000000000..46fdcc81ef
--- /dev/null
+++ b/libgnomecanvas/Makefile.am
@@ -0,0 +1,83 @@
+privsolib_LTLIBRARIES = libgnomecanvas-2.la
+
+libgnomecanvas_2_la_CPPFLAGS = \
+ $(AM_CPPFLAGS) \
+ -I$(top_srcdir) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ -DGNOMECANVASLIBDIR=\""$(libdir)"\" \
+ -DGNOMECANVASDATADIR=\""$(datadir)"\" \
+ -DGNOMECANVASPIXMAPDIR=\""$(datadir)/pixmaps"\" \
+ -DGNOMECANVASBINDIR=\""$(bindir)"\" \
+ -DGNOMECANVASLOCALSTATEDIR=\""$(localstatedir)"\" \
+ -DG_LOG_DOMAIN=\"GnomeCanvas\"
+
+libgnomecanvas_2_la_LIBADD = \
+ $(top_builddir)/libart_lgpl/libart_lgpl_2.la \
+ $(GNOME_PLATFORM_LIBS)
+
+libgnomecanvas_2_la_LDFLAGS = $(NO_UNDEFINED)
+
+libgnomecanvas_2_la_SOURCES = \
+ gailcanvas.c \
+ gailcanvas.h \
+ gailcanvasgroup.c \
+ gailcanvasgroup.h \
+ gailcanvasgroupfactory.c \
+ gailcanvasgroupfactory.h \
+ gailcanvasitem.c \
+ gailcanvasitem.h \
+ gailcanvasitemfactory.c \
+ gailcanvasitemfactory.h \
+ gailcanvastext.c \
+ gailcanvastext.h \
+ gailcanvastextfactory.c \
+ gailcanvastextfactory.h \
+ gailcanvaswidget.c \
+ gailcanvaswidget.h \
+ gailcanvaswidgetfactory.c \
+ gailcanvaswidgetfactory.h \
+ gnome-canvas-bpath.c \
+ gnome-canvas-bpath.h \
+ gnome-canvas-clipgroup.c \
+ gnome-canvas-clipgroup.h \
+ gnome-canvas-i18n.h \
+ gnome-canvas-line.c \
+ gnome-canvas-line.h \
+ gnome-canvas-path-def.c \
+ gnome-canvas-path-def.h \
+ gnome-canvas-pixbuf.c \
+ gnome-canvas-pixbuf.h \
+ gnome-canvas-polygon.c \
+ gnome-canvas-polygon.h \
+ gnome-canvas-rect-ellipse.c \
+ gnome-canvas-rect-ellipse.h \
+ gnome-canvas-rich-text.c \
+ gnome-canvas-rich-text.h \
+ gnome-canvas-shape-private.h \
+ gnome-canvas-shape.c \
+ gnome-canvas-shape.h \
+ gnome-canvas-text.c \
+ gnome-canvas-text.h \
+ gnome-canvas-util.c \
+ gnome-canvas-util.h \
+ gnome-canvas-widget.c \
+ gnome-canvas-widget.h \
+ gnome-canvas.c \
+ gnome-canvas.h \
+ libgnomecanvas.h \
+ libgnomecanvastypes.c
+
+MARSHAL_GENERATED = \
+ gnome-canvas-marshal.c \
+ gnome-canvas-marshal.h
+
+@EVO_MARSHAL_RULE@
+
+BUILT_SOURCES = $(MARSHAL_GENERATED)
+
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = \
+ gnome-canvas-marshal.list
+
+-include $(top_srcdir)/git.mk