aboutsummaryrefslogtreecommitdiffstats
path: root/libemail-engine/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2012-01-25 11:18:20 +0800
committerMatthew Barnes <mbarnes@redhat.com>2012-01-25 11:21:59 +0800
commitd75f6c636406385abb50025b4c371dec262b1c4b (patch)
tree62a62a06cb6a6b78373dd2e13a2c198d5ef9e3a0 /libemail-engine/Makefile.am
parentfa244511cec16843162db9896ecbb4350d827957 (diff)
downloadgsoc2013-evolution-d75f6c636406385abb50025b4c371dec262b1c4b.tar
gsoc2013-evolution-d75f6c636406385abb50025b4c371dec262b1c4b.tar.gz
gsoc2013-evolution-d75f6c636406385abb50025b4c371dec262b1c4b.tar.bz2
gsoc2013-evolution-d75f6c636406385abb50025b4c371dec262b1c4b.tar.lz
gsoc2013-evolution-d75f6c636406385abb50025b4c371dec262b1c4b.tar.xz
gsoc2013-evolution-d75f6c636406385abb50025b4c371dec262b1c4b.tar.zst
gsoc2013-evolution-d75f6c636406385abb50025b4c371dec262b1c4b.zip
Bug 668479: Missing transport-only accounts in Preferences
Evolution kinda sorta supports multiple identities by allowing users to set up so-called "transport-only" accounts by choosing "None" for the account type. Add a CamelStore subclass for those types of accounts so they get added to EMailAccountStore. It's just a stupid hack to keep another stupid hack working, but this should sustain us until we can support multiple identities FOR REAL.
Diffstat (limited to 'libemail-engine/Makefile.am')
-rw-r--r--libemail-engine/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libemail-engine/Makefile.am b/libemail-engine/Makefile.am
index 88a0227aab..ce0a1ab392 100644
--- a/libemail-engine/Makefile.am
+++ b/libemail-engine/Makefile.am
@@ -20,6 +20,7 @@ libemail_engine_la_CPPFLAGS = \
libmailengineincludedir = $(privincludedir)/libemail-engine
libmailengineinclude_HEADERS = \
+ camel-null-store.h \
e-mail-enums.h \
e-mail-enumtypes.h \
e-mail-folder-utils.h \
@@ -36,6 +37,7 @@ libmailengineinclude_HEADERS = \
libemail_engine_la_SOURCES = \
$(libmailengineinclude_HEADERS) \
+ camel-null-store.c \
e-mail-enumtypes.c \
e-mail-folder-utils.c \
e-mail-junk-filter.c \