aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorJP Rosevear <jpr@helixcode.com>2000-12-20 07:09:31 +0800
committerJP Rosevear <jpr@src.gnome.org>2000-12-20 07:09:31 +0800
commitfff1110610062f03b1cc7ffee1c3e076cfe61bdd (patch)
treeaa80a27955ff482b7c2924a766c0b9512b8b55da /e-util/Makefile.am
parent739f0eda9d6a00377350fc343a640e999d8e9255 (diff)
downloadgsoc2013-evolution-fff1110610062f03b1cc7ffee1c3e076cfe61bdd.tar
gsoc2013-evolution-fff1110610062f03b1cc7ffee1c3e076cfe61bdd.tar.gz
gsoc2013-evolution-fff1110610062f03b1cc7ffee1c3e076cfe61bdd.tar.bz2
gsoc2013-evolution-fff1110610062f03b1cc7ffee1c3e076cfe61bdd.tar.lz
gsoc2013-evolution-fff1110610062f03b1cc7ffee1c3e076cfe61bdd.tar.xz
gsoc2013-evolution-fff1110610062f03b1cc7ffee1c3e076cfe61bdd.tar.zst
gsoc2013-evolution-fff1110610062f03b1cc7ffee1c3e076cfe61bdd.zip
Convert cal component strings to pilot character set
2000-12-19 JP Rosevear <jpr@helixcode.com> * conduits/calendar/calendar-conduit.c (local_record_from_comp): Convert cal component strings to pilot character set (comp_from_remote_record): vice versa * conduits/todo/todo-conduit.c: Same as above 2000-12-19 JP Rosevear <jpr@helixcode.com> * conduit/address-conduit.c (local_record_from_ecard): Convert ecard strings to pilot encodings 2000-12-19 JP Rosevear <jpr@helixcode.com> * e-pilot-util.c (e_pilot_utf8_to_pchar): Convert utf8 strings to pilot character set (e_pilot_utf8_from_pchar): vice versa * Makefile.am: Conditionally build e-pilot-util.[hc] because they depend on pilot-link stuff svn path=/trunk/; revision=7090
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index e01b827ede..eb42fef5e0 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -7,9 +7,9 @@ INCLUDES = \
$(GNOME_INCLUDEDIR) \
$(EXTRA_GNOME_CFLAGS) \
$(UNICODE_CFLAGS) \
+ $(PISOCK_INCLUDEDIR) \
-DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
- -DG_LOG_DOMAIN=\"e-utils\" \
- $(UNICODE_CFLAGS)
+ -DG_LOG_DOMAIN=\"e-utils\"
noinst_LTLIBRARIES = libeutil.la libeutil-static.la \
libeconduit.la libeconduit-static.la
@@ -45,9 +45,16 @@ libeutil_la_LIBADD = $(UNICODE_LIBS)
libeutil_static_la_SOURCES = $(libeutil_la_SOURCES)
libeutil_static_la_LDFLAGS = --all-static
+if ENABLE_PILOT_CONDUITS
+pl_needed = e-pilot-util.c e-pilot-util.h
+else
+pl_needed =
+endif
+
libeconduit_la_SOURCES = \
e-pilot-map.c \
- e-pilot-map.h
+ e-pilot-map.h \
+ $(pl_needed)
libeconduit_static_la_SOURCES = $(libeconduit_la_SOURCES)
libeconduit_static_la_LDFLAGS = --all-static