aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2009-11-06 22:58:44 +0800
committerMatthew Barnes <mbarnes@redhat.com>2009-11-08 03:01:45 +0800
commitb2dd9c153519d315f96bfd760e91a6f6b32affd6 (patch)
tree059f35ef00dad51a639076bec887e563a2fbe385 /e-util/Makefile.am
parenta1f990ef82d92f723c609ad6a5a7764ff55a641d (diff)
downloadgsoc2013-evolution-b2dd9c153519d315f96bfd760e91a6f6b32affd6.tar
gsoc2013-evolution-b2dd9c153519d315f96bfd760e91a6f6b32affd6.tar.gz
gsoc2013-evolution-b2dd9c153519d315f96bfd760e91a6f6b32affd6.tar.bz2
gsoc2013-evolution-b2dd9c153519d315f96bfd760e91a6f6b32affd6.tar.lz
gsoc2013-evolution-b2dd9c153519d315f96bfd760e91a6f6b32affd6.tar.xz
gsoc2013-evolution-b2dd9c153519d315f96bfd760e91a6f6b32affd6.tar.zst
gsoc2013-evolution-b2dd9c153519d315f96bfd760e91a6f6b32affd6.zip
Prototype EIOActivity, which integrates with GIO.
EIOActivity implements the GAsyncResult interface, and the idea is to use this instead of GSimpleAsyncResult. In addition to the features offered by EActivity, it also contains GAsyncReadyCallback information and a GCancellable. - Calling e_activity_cancel() triggers the GCancellable. - Calling e_activity_complete() triggers the GAsyncReadyCallback. Functions that follow GIO's asynchronous pattern should return an EIOActivity (cast as an EActivity) instead of 'void', so it can be handed to an EShellBackend or whatever else dispatches activities. This is not yet feature-complete. It's missing API for storing result values and GErrors. I don't have a complete picture of the final API in my head yet, so I'll copy things over from GSimpleAsyncResult as needed.
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 2d66a708a4..bc5e7cd4fc 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -29,6 +29,7 @@ eutilinclude_HEADERS = \
e-html-utils.h \
e-icon-factory.h \
e-import.h \
+ e-io-activity.h \
e-logger.h \
e-marshal.h \
e-mktemp.h \
@@ -102,6 +103,7 @@ libeutil_la_SOURCES = \
e-html-utils.c \
e-icon-factory.c \
e-import.c \
+ e-io-activity.c \
e-logger.c \
e-marshal.c \
e-mktemp.c \