aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorSrinivasa Ragavan <sragavan@novell.com>2007-12-17 04:19:53 +0800
committerSrinivasa Ragavan <sragavan@src.gnome.org>2007-12-17 04:19:53 +0800
commit5b89cbe4f598387a56d22627558b5308da6044bc (patch)
tree620d37062cec0df7cbfa107d8317b62fb28ce9ee /e-util/Makefile.am
parent9bf01a179e346a25967a0898c900c863ed7b95db (diff)
downloadgsoc2013-evolution-5b89cbe4f598387a56d22627558b5308da6044bc.tar
gsoc2013-evolution-5b89cbe4f598387a56d22627558b5308da6044bc.tar.gz
gsoc2013-evolution-5b89cbe4f598387a56d22627558b5308da6044bc.tar.bz2
gsoc2013-evolution-5b89cbe4f598387a56d22627558b5308da6044bc.tar.lz
gsoc2013-evolution-5b89cbe4f598387a56d22627558b5308da6044bc.tar.xz
gsoc2013-evolution-5b89cbe4f598387a56d22627558b5308da6044bc.tar.zst
gsoc2013-evolution-5b89cbe4f598387a56d22627558b5308da6044bc.zip
** Non-intrusive errror reporting and basic logging support.
2007-12-17 Srinivasa Ragavan <sragavan@novell.com> ** Non-intrusive errror reporting and basic logging support. * em-folder-browser.c: (emfb_help_debug): Invoke the debug menu. * evolution-mail.schemas.in: Schema for error timeout and level. * mail-component.c: (mail_component_init), (render_pixbuf), (render_level), (render_date), (append_logs), (spin_value_changed), (mail_component_show_logger): Handle the lifecycle of the logger. * mail-component.h: Api to show the logger. * mail-config.c: (gconf_error_time_changed), (gconf_error_level_changed), (mail_config_init), (mail_config_get_error_timeout), (mail_config_get_error_level): Load and get the error time and level. * mail-config.h: * mail-mt.c: (mail_msg_set_cancelable), (mail_msg_new), (end_event_callback), (mail_msg_free), (mail_msg_check_error), (operation_cancel), (do_op_status): Revamp the error handling. * mail-mt.h: * mail-ops.c: (send_queue_send), (mail_send_queue): Handle the send/receive case of error reporting separately. * mail-send-recv.c: (free_send_info), (mail_send): 2007-12-17 Srinivasa Ragavan <sragavan@novell.com> ** Revamped Activity handler and task bar/widget for non-intrusive error reporting * e-activity-handler.c: (activity_info_new), (activity_info_free), (task_widget_new_from_activity_info), (setup_task_bar), (e_activity_handler_init), (e_activity_handler_set_error_flush_time), (e_activity_handler_set_logger), (cancel_wrapper), (e_activity_handler_cancelable_operation_started), (e_activity_handler_operation_started), (handle_error), (error_cleanup), (e_activity_handler_make_error), (e_activity_handler_operation_set_error), (e_activity_handler_operation_progressing), (e_activity_handler_operation_finished): * e-activity-handler.h: * e-task-bar.c: (e_task_bar_prepend_task), (e_task_bar_remove_task_from_id), (e_task_bar_remove_task), (e_task_bar_get_task_widget_from_id): * e-task-bar.h: * e-task-widget.c: (e_task_widget_init), (button_press_event_cb), (prepare_popup), (e_task_widget_construct), (e_task_widget_new_with_cancel), (e_task_widget_new), (e_task_widget_update_image): * e-task-widget.h: 2007-12-17 Srinivasa Ragavan <sragavan@novell.com> * Makefile.am: Add e-logger.[ch] to compilation * e-error.c: (e_error_newv): Add primary/secondary text to the error dialog to the gobject as data. * e-logger.[ch]: A new logger provision Evolution. 2007-12-17 Srinivasa Ragavan <sragavan@novell.com> * evolution-mail-global.xml: Add Debug Log menu item for mailer. * evolution.xml: Add place holder for Debug menu item. svn path=/trunk/; revision=34712
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index 8ae7c41aa8..3031358452 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -56,6 +56,7 @@ eutilinclude_HEADERS = \
e-html-utils.h \
e-icon-factory.h \
e-import.h \
+ e-logger.h \
e-menu.h \
e-mktemp.h \
e-print.h \
@@ -94,6 +95,7 @@ libeutil_la_SOURCES = \
e-html-utils.c \
e-icon-factory.c \
e-import.c \
+ e-logger.c \
e-menu.c \
e-mktemp.c \
e-plugin.c \