aboutsummaryrefslogtreecommitdiffstats
path: root/e-util/Makefile.am
diff options
context:
space:
mode:
authorPeter Williams <peterw@ximian.com>2002-07-18 05:03:19 +0800
committerPeter Williams <peterw@src.gnome.org>2002-07-18 05:03:19 +0800
commit515ebfd45c748cf31e2f45fe9180f97e08051498 (patch)
treed4df60220d5b044b3c084dadbd8d023bae1b4422 /e-util/Makefile.am
parent6485e5fcf75cd73418204e444418925134e3bdab (diff)
downloadgsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.gz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.bz2
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.lz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.xz
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.tar.zst
gsoc2013-evolution-515ebfd45c748cf31e2f45fe9180f97e08051498.zip
Install libversit.a so that people compiling against the addressbook can
2002-07-09 Peter Williams <peterw@ximian.com> * libversit/Makefile.am (privlib_LIBRARIES): Install libversit.a so that people compiling against the addressbook can do so successfully. * Makefile.am: create our *Conf.sh files and dist them and install them. * configure.in: Define and subst some variables that the Conf.sh file need. 2002-07-08 Peter Williams <peterw@ximian.com> * backend/ebook/Makefile.am: Install libebook-static.la. Also change --all-static to -all-static, which is the right flag. * backend/pas/Makefile.am: Install the PAS headers in $(includedir)/evolution/pas. Install libpas.a 2002-07-08 Peter Williams <peterw@ximian.com> * cal-util/Makefile.am: Install libcal-util-static.la and fix the -all-static flag to make it install statically. * pcs/Makefile.am: Install libpcs.a and its headers. * pcs/cal-backend-util.h: Same sort of include namespacing fix, but for pcs. * pcs/cal.h: * pcs/query.h: * pcs/cal-factory.h: * pcs/cal-backend.h: * pcs/cal-backend-file.h: Same. 2002-07-17 Peter Williams <peterw@ximian.com> * calendar/cal-util/Makefile.am (GTKDOC_LIBS): Because we're using libtool as our LD, we can reference .la's and libtool will DTRT for us. * calendar/cal-client/Makefile.am (GTKDOC_LIBS): Same here. 2002-07-03 Peter Williams <peterw@ximian.com> * Makefile.am: Install libeutil, libeconduit, and libedb3util and their headers. 2002-07-08 Peter Williams <peterw@ximian.com> * Makefile.am: Reference the new libefilterbar.a. 2002-07-12 Peter Williams <peterw@ximian.com> * Makefile.am (INCLUDES): Add -I$(builddir)/libical/src/libical for the generated ical.h (some headers rely on this because they too get installed.) 2002-07-09 Peter Williams <peterw@ximian.com> * e-timezone-dialog/Makefile.am: Add -I$(top_builddir)/libical/src/libical; some headers that we rely on get installed, so they point to the ical.h that gets generated and installed; consequently we need to be able to find the generated ical.h * misc/Makefile.am: Install libemiscwidgets.a and its headers. However, break EFilterBar into a separate libefilterbar.a because we don't want the installed library to depend on libfilter. svn path=/trunk/; revision=17496
Diffstat (limited to 'e-util/Makefile.am')
-rw-r--r--e-util/Makefile.am86
1 files changed, 49 insertions, 37 deletions
diff --git a/e-util/Makefile.am b/e-util/Makefile.am
index ebcb439c4e..f7b4bb4d8c 100644
--- a/e-util/Makefile.am
+++ b/e-util/Makefile.am
@@ -2,6 +2,10 @@ SUBDIRS = . ename
imagesdir = $(datadir)/images/evolution
+eutilincludedir = $(includedir)/evolution/e-util
+econdincludedir = $(includedir)/evolution/e-conduit
+edb3includedir = $(includedir)/evolution/e-db3util
+
INCLUDES = \
-I$(top_srcdir) \
-DEVOLUTION_IMAGES=\""$(imagesdir)"\" \
@@ -11,74 +15,79 @@ INCLUDES = \
$(PISOCK_CFLAGS) \
$(E_UTIL_CFLAGS)
-noinst_LTLIBRARIES = libeutil.la libeutil-static.la \
- libeconduit.la libeconduit-static.la \
- libedb3util.la
+privlib_LTLIBRARIES = libeutil.la libedb3util.la libeconduit.la
+noinst_LTLIBRARIES = libeutil-static.la libeconduit-static.la
-libeutil_la_SOURCES = \
- e-bonobo-factory-util.c \
+eutilinclude_HEADERS = \
e-bonobo-factory-util.h \
- e-categories-master-list-wombat.c \
e-categories-master-list-wombat.h \
- e-categories-config.c \
e-categories-config.h \
- e-corba-utils.c \
e-corba-utils.h \
- e-dialog-utils.c \
e-dialog-utils.h \
- e-dialog-widgets.c \
e-dialog-widgets.h \
- e-gtk-utils.c \
e-gtk-utils.h \
- e-gui-utils.c \
e-gui-utils.h \
- e-host-utils.c \
e-host-utils.h \
- e-html-utils.c \
e-html-utils.h \
- e-iterator.c \
e-iterator.h \
- e-lang-utils.c \
e-lang-utils.h \
- e-list-iterator.c \
e-list-iterator.h \
- e-list.c \
e-list.h \
- e-memory.c \
e-memory.h \
- e-mktemp.c \
e-mktemp.h \
- e-msgport.c \
e-msgport.h \
- e-passwords.c \
e-passwords.h \
- e-path.c \
e-path.h \
- e-request.c \
e-request.h \
- e-sexp.c \
e-sexp.h \
- e-time-utils.c \
e-time-utils.h \
- e-url.c \
e-url.h \
- md5-utils.c \
md5-utils.h
+libeutil_la_SOURCES = \
+ $(eutilinclude_HEADERS) \
+ e-bonobo-factory-util.c \
+ e-categories-master-list-wombat.c \
+ e-categories-config.c \
+ e-corba-utils.c \
+ e-dialog-utils.c \
+ e-dialog-widgets.c \
+ e-gtk-utils.c \
+ e-gui-utils.c \
+ e-host-utils.c \
+ e-html-utils.c \
+ e-iterator.c \
+ e-lang-utils.c \
+ e-list-iterator.c \
+ e-list.c \
+ e-memory.c \
+ e-mktemp.c \
+ e-msgport.c \
+ e-passwords.c \
+ e-path.c \
+ e-request.c \
+ e-sexp.c \
+ e-time-utils.c \
+ e-url.c \
+ md5-utils.c
+
libeutil_la_LIBADD = $(E_UTIL_LIBS)
libeutil_static_la_SOURCES = $(libeutil_la_SOURCES)
libeutil_static_la_LIBADD = $(libeutil_la_LIBADD)
-libeutil_static_la_LDFLAGS = --all-static
+libeutil_static_la_LDFLAGS = -all-static
-pilot_sources = \
- e-pilot-map.c \
+econdinclude_HEADERS = \
e-pilot-map.h \
- e-pilot-settings.c \
e-pilot-settings.h \
- e-pilot-util.c \
e-pilot-util.h
+pilot_sources = \
+ $(econdinclude_HEADERS) \
+ e-pilot-map.c \
+ e-pilot-settings.c \
+ e-pilot-util.c
+
if ENABLE_PILOT_CONDUITS
pilot_compile = $(pilot_sources)
else
@@ -88,12 +97,15 @@ endif
libeconduit_la_SOURCES = $(pilot_compile)
libeconduit_static_la_SOURCES = $(libeconduit_la_SOURCES)
-libeconduit_static_la_LDFLAGS = --all-static
+libeconduit_static_la_LDFLAGS = -all-static
EXTRA_DIST = $(pilot_sources)
-libedb3util_la_SOURCES = \
- e-db3-utils.c \
+edb3include_HEADERS = \
e-db3-utils.h \
- e-dbhash.c \
e-dbhash.h
+
+libedb3util_la_SOURCES = \
+ $(edb3include_HEADERS) \
+ e-db3-utils.c \
+ e-dbhash.c