aboutsummaryrefslogtreecommitdiffstats
path: root/doc/reference/shell/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@src.gnome.org>2008-09-15 22:55:41 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2008-09-15 22:55:41 +0800
commit7d2c28c02c6ecddcf492f385cacbd3d24ac215db (patch)
tree938e7a0b30062bbf4dbd180fa4363113018fb7e1 /doc/reference/shell/Makefile.am
parent8f2b4cc6faf5a2fedbe6e11f340d492d4698072a (diff)
downloadgsoc2013-evolution-7d2c28c02c6ecddcf492f385cacbd3d24ac215db.tar
gsoc2013-evolution-7d2c28c02c6ecddcf492f385cacbd3d24ac215db.tar.gz
gsoc2013-evolution-7d2c28c02c6ecddcf492f385cacbd3d24ac215db.tar.bz2
gsoc2013-evolution-7d2c28c02c6ecddcf492f385cacbd3d24ac215db.tar.lz
gsoc2013-evolution-7d2c28c02c6ecddcf492f385cacbd3d24ac215db.tar.xz
gsoc2013-evolution-7d2c28c02c6ecddcf492f385cacbd3d24ac215db.tar.zst
gsoc2013-evolution-7d2c28c02c6ecddcf492f385cacbd3d24ac215db.zip
Begin documenting the new shell design.
svn path=/branches/kill-bonobo/; revision=36337
Diffstat (limited to 'doc/reference/shell/Makefile.am')
-rw-r--r--doc/reference/shell/Makefile.am147
1 files changed, 147 insertions, 0 deletions
diff --git a/doc/reference/shell/Makefile.am b/doc/reference/shell/Makefile.am
new file mode 100644
index 0000000000..6a19153634
--- /dev/null
+++ b/doc/reference/shell/Makefile.am
@@ -0,0 +1,147 @@
+## Process this file with automake to produce Makefile.in
+
+# We require automake 1.6 at least.
+AUTOMAKE_OPTIONS = 1.6
+
+# The name of the module, e.g. 'glib'.
+DOC_MODULE=eshell
+
+# The top-level SGML file. You can change this if you want to.
+DOC_MAIN_SGML_FILE=$(DOC_MODULE)-docs.sgml
+
+# The directory containing the source code. Relative to $(srcdir).
+# gtk-doc will search all .c & .h files beneath here for inline comments
+# documenting the functions and macros.
+# e.g. DOC_SOURCE_DIR=../../../gtk
+DOC_SOURCE_DIR=../../../shell
+
+# Extra options to pass to gtkdoc-scangobj. Not normally needed.
+SCANGOBJ_OPTIONS=
+
+# Extra options to supply to gtkdoc-scan.
+# e.g. SCAN_OPTIONS=--deprecated-guards="GTK_DISABLE_DEPRECATED"
+SCAN_OPTIONS=
+
+# Extra options to supply to gtkdoc-mkdb.
+# e.g. MKDB_OPTIONS=--sgml-mode --output-format=xml
+MKDB_OPTIONS=--sgml-mode --output-format=xml
+
+# Extra options to supply to gtkdoc-mktmpl
+# e.g. MKTMPL_OPTIONS=--only-section-tmpl
+MKTMPL_OPTIONS=
+
+# Extra options to supply to gtkdoc-fixref. Not normally needed.
+# e.g. FIXXREF_OPTIONS=--extra-dir=../gdk-pixbuf/html --extra-dir=../gdk/html
+FIXXREF_OPTIONS=
+
+# Used for dependencies. The docs will be rebuilt if any of these change.
+# e.g. HFILE_GLOB=$(top_srcdir)/gtk/*.h
+# e.g. CFILE_GLOB=$(top_srcdir)/gtk/*.c
+HFILE_GLOB=$(top_srcdir)/shell/*.h
+CFILE_GLOB=$(top_srcdir)/shell/*.c
+
+# Header files to ignore when scanning.
+# e.g. IGNORE_HFILES=gtkdebug.h gtkintl.h
+IGNORE_HFILES=e-shell-window-private.h
+
+# Images to copy into HTML directory.
+# e.g. HTML_IMAGES=$(top_srcdir)/gtk/stock-icons/stock_about_24.png
+HTML_IMAGES=
+
+# Extra SGML files that are included by $(DOC_MAIN_SGML_FILE).
+# e.g. content_files=running.sgml building.sgml changes-2.0.sgml
+content_files=
+
+# SGML files where gtk-doc abbrevations (#GtkWidget) are expanded
+# These files must be listed here *and* in content_files
+# e.g. expand_content_files=running.sgml
+expand_content_files=
+
+# CFLAGS and LDFLAGS for compiling gtkdoc-scangobj with your library.
+# Only needed if you are using gtkdoc-scangobj to dynamically query widget
+# signals and properties.
+# e.g. INCLUDES=-I$(top_srcdir) -I$(top_builddir) $(GTK_DEBUG_FLAGS)
+# e.g. GTKDOC_LIBS=$(top_builddir)/gtk/$(gtktargetlib)
+INCLUDES= \
+ -I$(top_srcdir) \
+ -I$(SHELL_CFLAGS)
+GTKDOC_LIBS= \
+ $(top_builddir)/shell/e-shell.o \
+ $(top_builddir)/shell/e-shell-importer.o \
+ $(top_builddir)/shell/e-shell-nm.o \
+ $(top_builddir)/shell/e-shell-window-private.o \
+ $(top_builddir)/shell/es-event.o \
+ $(top_builddir)/shell/.libs/e-activity-handler.o \
+ $(top_builddir)/shell/.libs/e-shell-content.o \
+ $(top_builddir)/shell/.libs/e-shell-marshal.o \
+ $(top_builddir)/shell/.libs/e-shell-module.o \
+ $(top_builddir)/shell/.libs/e-shell-sidebar.o \
+ $(top_builddir)/shell/.libs/e-shell-switcher.o \
+ $(top_builddir)/shell/.libs/e-shell-taskbar.o \
+ $(top_builddir)/shell/.libs/e-shell-view.o \
+ $(top_builddir)/shell/.libs/e-shell-window-actions.o \
+ $(top_builddir)/shell/.libs/e-shell-window.o \
+ $(top_builddir)/e-util/.libs/e-dialog-utils.o \
+ $(top_builddir)/e-util/.libs/e-error.o \
+ $(top_builddir)/e-util/.libs/e-event.o \
+ $(top_builddir)/e-util/.libs/e-icon-factory.o \
+ $(top_builddir)/e-util/.libs/e-import.o \
+ $(top_builddir)/e-util/.libs/e-logger.o \
+ $(top_builddir)/e-util/.libs/e-mktemp.o \
+ $(top_builddir)/e-util/.libs/e-plugin.o \
+ $(top_builddir)/e-util/.libs/e-plugin-ui.o \
+ $(top_builddir)/e-util/.libs/e-popup.o \
+ $(top_builddir)/e-util/.libs/e-print.o \
+ $(top_builddir)/e-util/.libs/e-util.o \
+ $(top_builddir)/e-util/.libs/e-util-labels.o \
+ $(top_builddir)/e-util/.libs/e-xml-utils.o \
+ $(top_builddir)/e-util/.libs/gconf-bridge.o \
+ $(top_builddir)/filter/.libs/filter-code.o \
+ $(top_builddir)/filter/.libs/filter-colour.o \
+ $(top_builddir)/filter/.libs/filter-datespec.o \
+ $(top_builddir)/filter/.libs/filter-element.o \
+ $(top_builddir)/filter/.libs/filter-file.o \
+ $(top_builddir)/filter/.libs/filter-input.o \
+ $(top_builddir)/filter/.libs/filter-int.o \
+ $(top_builddir)/filter/.libs/filter-label.o \
+ $(top_builddir)/filter/.libs/filter-option.o \
+ $(top_builddir)/filter/.libs/filter-part.o \
+ $(top_builddir)/filter/.libs/filter-rule.o \
+ $(top_builddir)/filter/.libs/rule-context.o \
+ $(top_builddir)/filter/.libs/rule-editor.o \
+ $(top_builddir)/widgets/menus/.libs/gal-define-views-dialog.o \
+ $(top_builddir)/widgets/menus/.libs/gal-view-collection.o \
+ $(top_builddir)/widgets/menus/.libs/gal-view-factory.o \
+ $(top_builddir)/widgets/menus/.libs/gal-view-instance.o \
+ $(top_builddir)/widgets/menus/.libs/gal-view-instance-save-as-dialog.o \
+ $(top_builddir)/widgets/menus/.libs/gal-view-new-dialog.o \
+ $(top_builddir)/widgets/menus/.libs/gal-view.o \
+ $(top_builddir)/widgets/misc/.libs/e-action-combo-box.o \
+ $(top_builddir)/widgets/misc/.libs/e-icon-entry.o \
+ $(top_builddir)/widgets/misc/.libs/e-gui-utils.o \
+ $(top_builddir)/widgets/misc/.libs/e-menu-tool-button.o \
+ $(top_builddir)/widgets/misc/.libs/e-online-button.o \
+ $(top_builddir)/widgets/misc/.libs/e-popup-menu.o \
+ $(top_builddir)/widgets/misc/.libs/e-preferences-window.o \
+ $(top_builddir)/widgets/misc/.libs/e-spinner.o \
+ $(top_builddir)/widgets/misc/.libs/e-task-widget.o \
+ $(top_builddir)/widgets/misc/.libs/e-unicode.o \
+ -ledataserver-1.2 \
+ -ledataserverui-1.2 \
+ $(SHELL_LIBS)
+
+# This includes the standard gtk-doc make rules, copied by gtkdocize.
+include $(top_srcdir)/gtk-doc.make
+
+# Other files to distribute
+# e.g. EXTRA_DIST += version.xml.in
+EXTRA_DIST +=
+
+# Files not to distribute
+# for --rebuild-types in $(SCAN_OPTIONS), e.g. $(DOC_MODULE).types
+# for --rebuild-sections in $(SCAN_OPTIONS) e.g. $(DOC_MODULE)-sections.txt
+#DISTCLEANFILES +=
+
+# Comment this out if you want your docs-status tested during 'make check'
+#TESTS = $(GTKDOC_CHECK)
+