aboutsummaryrefslogtreecommitdiffstats
path: root/doc/reference/evolution-util/Makefile.am
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2013-05-27 02:57:43 +0800
committerMatthew Barnes <mbarnes@redhat.com>2013-05-28 21:56:30 +0800
commit6c9a3243c9b335cb7e5873b15562263e74293dc2 (patch)
treeb94ece5ad2b366aaa9ed06843e74f8f5f14f9e2b /doc/reference/evolution-util/Makefile.am
parent5204abd40cac00e501e3c0823c18016343feec4f (diff)
downloadgsoc2013-evolution-6c9a3243c9b335cb7e5873b15562263e74293dc2.tar
gsoc2013-evolution-6c9a3243c9b335cb7e5873b15562263e74293dc2.tar.gz
gsoc2013-evolution-6c9a3243c9b335cb7e5873b15562263e74293dc2.tar.bz2
gsoc2013-evolution-6c9a3243c9b335cb7e5873b15562263e74293dc2.tar.lz
gsoc2013-evolution-6c9a3243c9b335cb7e5873b15562263e74293dc2.tar.xz
gsoc2013-evolution-6c9a3243c9b335cb7e5873b15562263e74293dc2.tar.zst
gsoc2013-evolution-6c9a3243c9b335cb7e5873b15562263e74293dc2.zip
Rename libeutil to libevolution-util.
To make Evolution's shared libraries more consistent. Also rename the documentation module to evolution-util.
Diffstat (limited to 'doc/reference/evolution-util/Makefile.am')
-rw-r--r--doc/reference/evolution-util/Makefile.am73
1 files changed, 73 insertions, 0 deletions
diff --git a/doc/reference/evolution-util/Makefile.am b/doc/reference/evolution-util/Makefile.am
new file mode 100644
index 0000000000..a7055a4f39
--- /dev/null
+++ b/doc/reference/evolution-util/Makefile.am
@@ -0,0 +1,73 @@
+# The name of the module.
+DOC_MODULE = evolution-util
+
+# The top-level SGML file.
+DOC_MAIN_SGML_FILE = evolution-util-docs.sgml
+
+# Extra options to supply to gtkdoc-scan.
+SCAN_OPTIONS = --deprecated-guards="EDS_DISABLE_DEPRECATED"
+
+# The directory containing the source code. Relative to $(srcdir).
+DOC_SOURCE_DIR = $(top_srcdir)/e-util
+
+# Used for dependencies. The docs will be rebuilt if any of these change.
+HFILE_GLOB = $(top_srcdir)/e-util/*.h
+CFILE_GLOB = $(top_srcdir)/e-util/*.c
+
+# Ignore all accessiblity headers.
+IGNORE_HFILES = \
+ e-marshal.h \
+ e-table-col-dnd.h \
+ e-table-defines.h \
+ e-util-enumtypes.h \
+ e-util-private.h \
+ ea-calendar-cell.h \
+ ea-calendar-item.h \
+ ea-cell-table.h \
+ ea-factory.h \
+ ea-widgets.h \
+ gal-a11y-e-cell.h \
+ gal-a11y-e-cell-popup.h \
+ gal-a11y-e-cell-registry.h \
+ gal-a11y-e-cell-toggle.h \
+ gal-a11y-e-cell-tree.h \
+ gal-a11y-e-cell-vbox.h \
+ gal-a11y-e-table-click-to-add-factory.h \
+ gal-a11y-e-table-click-to-add.h \
+ gal-a11y-e-table-column-header.h \
+ gal-a11y-e-table-factory.h \
+ gal-a11y-e-table-item-factory.h \
+ gal-a11y-e-table-item.h \
+ gal-a11y-e-table.h \
+ gal-a11y-e-text-factory.h \
+ gal-a11y-e-text.h \
+ gal-a11y-e-tree-factory.h \
+ gal-a11y-e-tree.h \
+ gal-a11y-factory.h \
+ gal-a11y-util.h \
+ $(NULL)
+
+GTKDOC_CFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(EVOLUTION_DATA_SERVER_CFLAGS) \
+ $(GNOME_PLATFORM_CFLAGS) \
+ $(GTKHTML_CFLAGS) \
+ $(NULL)
+
+GTKDOC_LIBS = \
+ $(top_builddir)/e-util/libevolution-util.la \
+ $(EVOLUTION_DATA_SERVER_LIBS) \
+ $(GNOME_PLATFORM_LIBS) \
+ $(GTKHTML_LIBS) \
+ $(NULL)
+
+# Extra options to supply to gtkdoc-mkdb
+MKDB_OPTIONS = --output-format=xml --sgml-mode
+
+# This includes the standard gtk-doc make rules, copied by gtkdocize.
+include $(top_srcdir)/gtk-doc.make
+
+#TESTS = $(GTKDOC_CHECK)
+
+-include $(top_srcdir)/git.mk