aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-07-24 00:38:42 +0800
committerDan Winship <danw@src.gnome.org>2003-07-24 00:38:42 +0800
commitfb9b835fe3c590ede744c2a7b1508b6b418a0b8e (patch)
treede10bfbd01b12405ceeb8fa5ee4f21352edab821 /configure.in
parentb167ce08618496b4017274f5b5d5d0bfbebe7d85 (diff)
downloadgsoc2013-evolution-fb9b835fe3c590ede744c2a7b1508b6b418a0b8e.tar
gsoc2013-evolution-fb9b835fe3c590ede744c2a7b1508b6b418a0b8e.tar.gz
gsoc2013-evolution-fb9b835fe3c590ede744c2a7b1508b6b418a0b8e.tar.bz2
gsoc2013-evolution-fb9b835fe3c590ede744c2a7b1508b6b418a0b8e.tar.lz
gsoc2013-evolution-fb9b835fe3c590ede744c2a7b1508b6b418a0b8e.tar.xz
gsoc2013-evolution-fb9b835fe3c590ede744c2a7b1508b6b418a0b8e.tar.zst
gsoc2013-evolution-fb9b835fe3c590ede744c2a7b1508b6b418a0b8e.zip
Define EVO_MARSHAL_RULE, which creates glib marshaller .c and .h files
* configure.in: Define EVO_MARSHAL_RULE, which creates glib marshaller .c and .h files that don't cause gcc warnings * marshal.mk: The Makefile fragment used by EVO_MARSHAL_RULE. (Can't include newlines in an AC_SUBST, so we have to use AC_SUBST_FILE) * Makefile.am (EXTRA_DIST): add marshal.mk svn path=/trunk/; revision=21910
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 6d42574ac0..393f45a9c4 100644
--- a/configure.in
+++ b/configure.in
@@ -1016,6 +1016,15 @@ fi
AC_SUBST(OPENSSL_CFLAGS)
AC_SUBST(OPENSSL_LDFLAGS)
+dnl *******************
+dnl GObject marshalling
+dnl *******************
+AM_PATH_GLIB_2_0
+
+dnl We use AC_SUBST_FILE because AC_SUBST won't deal with newlines
+EVO_MARSHAL_RULE=$srcdir/marshal.mk
+AC_SUBST_FILE(EVO_MARSHAL_RULE)
+
dnl *************************
dnl CFLAGS and LIBS and stuff
dnl *************************
@@ -1030,8 +1039,6 @@ IDL_INCLUDES="-I "`pkg-config --variable=idldir libbonobo-2.0`" -I "`pkg-config
AC_MSG_RESULT($IDL_INCLUDES)
AC_SUBST(IDL_INCLUDES)
-AM_PATH_GLIB_2_0
-
dnl Utility macro to set compiler flags for a specific lib.
AC_DEFUN(EVO_SET_COMPILE_FLAGS, [
deps="$2"