aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFridrich Strba <FStrba@novell.com>2009-05-04 14:42:03 +0800
committerBharath Acharya <abharath@novell.com>2009-05-04 14:42:03 +0800
commitfb970ccf14e33d92cfb9409d44f7b06355e958fc (patch)
treefc92372706796fa2918b6614ff8d575a89b17faf /configure.in
parentf4ecf2d62fd8766fa0b0c7d6483d9a583459267c (diff)
downloadgsoc2013-evolution-fb970ccf14e33d92cfb9409d44f7b06355e958fc.tar
gsoc2013-evolution-fb970ccf14e33d92cfb9409d44f7b06355e958fc.tar.gz
gsoc2013-evolution-fb970ccf14e33d92cfb9409d44f7b06355e958fc.tar.bz2
gsoc2013-evolution-fb970ccf14e33d92cfb9409d44f7b06355e958fc.tar.lz
gsoc2013-evolution-fb970ccf14e33d92cfb9409d44f7b06355e958fc.tar.xz
gsoc2013-evolution-fb970ccf14e33d92cfb9409d44f7b06355e958fc.tar.zst
gsoc2013-evolution-fb970ccf14e33d92cfb9409d44f7b06355e958fc.zip
Add iconrc support for Evolution. The windows binary
would now have the Evolution icon.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d46a1f1a45..1bf1b0c0f4 100644
--- a/configure.in
+++ b/configure.in
@@ -169,6 +169,16 @@ AM_CONDITIONAL(OS_WIN32, [test $os_win32 = yes])
AC_SUBST(NO_UNDEFINED)
AC_SUBST(SOEXT)
+if test "$os_win32" = "yes"; then
+ AC_CHECK_TOOL(WINDRES, windres, :)
+else
+ WINDRES=":"
+fi
+
+AM_CONDITIONAL(HAVE_WINDRES, test "x$WINDRES" != "x:")
+
+AC_SUBST(WINDRES)
+
# Check for base dependencies early.
PKG_CHECK_MODULES(GNOME_PLATFORM,
[glib-2.0 >= glib_minimum_version