aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2008-01-01 21:22:31 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2008-01-01 21:22:31 +0800
commitf3546248ed3fbf5cf613ca25f0b7c024b073ca2b (patch)
tree535b835690b39c940914ce9e0524f62f10506629 /configure.in
parenta02303d7ccbc548316b1d37ef79165c7dfe928f8 (diff)
downloadgsoc2013-evolution-f3546248ed3fbf5cf613ca25f0b7c024b073ca2b.tar
gsoc2013-evolution-f3546248ed3fbf5cf613ca25f0b7c024b073ca2b.tar.gz
gsoc2013-evolution-f3546248ed3fbf5cf613ca25f0b7c024b073ca2b.tar.bz2
gsoc2013-evolution-f3546248ed3fbf5cf613ca25f0b7c024b073ca2b.tar.lz
gsoc2013-evolution-f3546248ed3fbf5cf613ca25f0b7c024b073ca2b.tar.xz
gsoc2013-evolution-f3546248ed3fbf5cf613ca25f0b7c024b073ca2b.tar.zst
gsoc2013-evolution-f3546248ed3fbf5cf613ca25f0b7c024b073ca2b.zip
Add --with[out]-help option to make it possible to skip building and
2008-01-01 Matthew Barnes <mbarnes@redhat.com> * configure.in: Add --with[out]-help option to make it possible to skip building and installing user documentation. (#504541) svn path=/trunk/; revision=34743
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 22 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index d84c49e324..e858b74db2 100644
--- a/configure.in
+++ b/configure.in
@@ -184,6 +184,17 @@ PKG_CHECK_MODULES(EVOLUTION_DATA_SERVER,
libegroupwise-$EDS_PACKAGE >= eds_minimum_version])
+dnl ******************
+dnl User documentation
+dnl ******************
+AC_MSG_CHECKING([whether to build user documentation])
+AC_ARG_WITH([help],
+ [AC_HELP_STRING([--with-help],
+ [Build user documentation [default=yes]])],
+ with_help="$withval", with_help="yes")
+AM_CONDITIONAL(WITH_HELP, test "x$with_help" != "xno")
+AC_MSG_RESULT($with_help)
+
dnl ******************************
dnl iconv checking
dnl ******************************
@@ -1813,7 +1824,6 @@ AC_ARG_ENABLE([default-binary],
AM_CONDITIONAL(DEFAULT_BINARY, test x$enable_default_binary = xyes)
-
dnl ********************
dnl KDE applnk directory
dnl ********************
@@ -2005,18 +2015,19 @@ echo "
fi
echo "
- LDAP support: $msg_ldap
- HAL: $HAVE_HAL"
+ LDAP support: $msg_ldap
+ HAL: $HAVE_HAL"
if test "$msg_nntp" = "yes"; then
echo "\
- NNTP support: $msg_nntp"
+ NNTP support: $msg_nntp"
fi
echo "\
- Pilot conduits: $msg_pilot
- Libnotify: $HAVE_LIBNOTIFY
- Kerberos 4/5: $msg_krb4/$msg_krb5
- SSL support: $msg_ssl
- SMIME support: $msg_smime
- Plugins: $msg_plugins
- DBus API version $DBUS_VERSION
+ Pilot conduits: $msg_pilot
+ Libnotify: $HAVE_LIBNOTIFY
+ Kerberos 4/5: $msg_krb4/$msg_krb5
+ SSL support: $msg_ssl
+ SMIME support: $msg_smime
+ Plugins: $msg_plugins
+ DBus API version: $DBUS_VERSION
+ User documentation: $with_help
"