aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2007-06-12 23:02:29 +0800
committerBastien Nocera <hadess@src.gnome.org>2007-06-12 23:02:29 +0800
commitd31f48d6dba8d4cfef36e30c9c0ef6894eb073ad (patch)
tree0ce613851aa758028d2b96f2ecf61e72a0ff42b1 /configure.in
parentfd3c9551a84a3a9d74dc00c0e04e7ffcc498f8a8 (diff)
downloadgsoc2013-evolution-d31f48d6dba8d4cfef36e30c9c0ef6894eb073ad.tar
gsoc2013-evolution-d31f48d6dba8d4cfef36e30c9c0ef6894eb073ad.tar.gz
gsoc2013-evolution-d31f48d6dba8d4cfef36e30c9c0ef6894eb073ad.tar.bz2
gsoc2013-evolution-d31f48d6dba8d4cfef36e30c9c0ef6894eb073ad.tar.lz
gsoc2013-evolution-d31f48d6dba8d4cfef36e30c9c0ef6894eb073ad.tar.xz
gsoc2013-evolution-d31f48d6dba8d4cfef36e30c9c0ef6894eb073ad.tar.zst
gsoc2013-evolution-d31f48d6dba8d4cfef36e30c9c0ef6894eb073ad.zip
Add support for the XF86Reply and XF86MailForward multimedia keys (Closes:
2007-06-12 Bastien Nocera <hadess@hadess.net> * em-folder-view.c: (emfv_list_key_press): Add support for the XF86Reply and XF86MailForward multimedia keys (Closes: #442631) 2007-06-12 Bastien Nocera <hadess@hadess.net> * e-msg-composer.c: (composer_key_pressed): Add support for the XF86Send multimedia key (Closes: #442631) 2007-06-12 Bastien Nocera <hadess@hadess.net> * configure.in: Detect the X11/XF86keysym.h header, and enable multimedia keys if available (Closes: #442631) svn path=/trunk/; revision=33668
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4e8f3d822e..31388c41b2 100644
--- a/configure.in
+++ b/configure.in
@@ -416,6 +416,24 @@ AC_SUBST(A11Y_CFLAGS)
AC_SUBST(A11Y_LIBS)
dnl **************************************************
+dnl * XF86 multimedia keys support
+dnl **************************************************
+have_xfree=no
+AC_COMPILE_IFELSE([
+ #include <X11/XF86keysym.h>
+ int main(int argc,char **argv) {
+ return 0;
+ }
+ ],
+ have_xfree=yes
+)
+AC_MSG_CHECKING(for X11 XFree86 headers)
+AC_MSG_RESULT([$have_xfree])
+if test x"$have_xfree" = "xyes" ; then
+ AC_DEFINE(HAVE_XFREE, 1, [defined if you have X11/XF86keysym.h])
+fi
+
+dnl **************************************************
dnl LDAP support.
dnl **************************************************
if test "$os_win32" != yes; then