aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2003-01-06 22:16:59 +0800
committerDan Winship <danw@src.gnome.org>2003-01-06 22:16:59 +0800
commitcd6da3a0c9804ca8c75b69d47e16ca67847c0b1f (patch)
treefe838d4a92498422c881eee50260dc266d836c3e /configure.in
parentb993405d21997f28daa51eafb771f3185e1642bd (diff)
downloadgsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.gz
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.bz2
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.lz
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.xz
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.tar.zst
gsoc2013-evolution-cd6da3a0c9804ca8c75b69d47e16ca67847c0b1f.zip
Use "Evolution", not "evolution", since that becomes the value of the
* configure.in (AC_INIT): Use "Evolution", not "evolution", since that becomes the value of the PACKAGE variable (privlibdir): parse $VERSION by hand since. EVOLUTION_MAJOR_VERSION, etc aren't defined any more (and trying to pass a variable to AC_INIT won't work). This and the above change fix the problem that privlibdir was being defined as "${libdir}/Evolution/." instead of "${libdir}/evolution/1.3" (GAL_VERSION): AC_SUBST this since it's needed in the .pc files (idldir): define this here rather than in each Makefile.am that needs it. (AC_OUTPUT): Add .pc files * Makefile.am (pkgconfig_DATA): Add pc files. (confexec_DATA): Remove this (fooConf.sh files) (SUBDIRS): Move filter earlier in the build. (I think it was calendar that depends on it now?) (%Conf.sh): Remove this. The .pc files are output by configure.in now. * camel.pc.in, evolution-addressbook.pc.in, evolution-calendar.pc.in, evolution-shell.pc.in: Replace the *Conf.sh files with these. In addition to the basic variables, include camel_providerdir (in camel.pc) and idldir, IDL_INCLUDES and privlibdir (in the others). svn path=/trunk/; revision=19241
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in51
1 files changed, 22 insertions, 29 deletions
diff --git a/configure.in b/configure.in
index 20c6903831..33c1da7e6d 100644
--- a/configure.in
+++ b/configure.in
@@ -1,27 +1,12 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.52)
-AC_INIT(Evolution, 1.3.0.99, http://bugzilla.ximian.com/enter_bug.cgi?product=Evolution)
+AC_INIT(evolution, 1.3.0.99, http://bugzilla.ximian.com/enter_bug.cgi?product=Evolution)
AC_CONFIG_SRCDIR(README)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
AM_CONFIG_HEADER(config.h)
-if test -f libversit/CVS/Repository; then
- case `cat libversit/CVS/Repository` in
- gnome-pim*)
- echo ""
- echo "ERROR: CVS working directory is out of date"
- echo "Please do:"
- echo " rm -rf libversit"
- echo " cvs update -d libversit"
- echo " automake libversit/Makefile"
- echo "and try again. We apologize for the inconvenience"
- exit 1
- ;;
- esac
-fi
-
AC_CANONICAL_HOST
AC_DEFINE_UNQUOTED(VERSION_COMMENT, "(Preview Release)")
@@ -1041,6 +1026,7 @@ dnl --- Flags to get all the GNOME stuff
dnl --- We require at least this version of GAL.
GAL_VERSION=0.0.9.99
+AC_SUBST(GAL_VERSION)
FULL_GNOME_DEPS="libbonoboui-2.0 gnome-vfs-2.0 libgnomeui-2.0 libglade-2.0 libgnomecanvas-2.0 libxml-2.0 gconf-2.0 gal-2.0 >= $GAL_VERSION"
@@ -1119,16 +1105,6 @@ dnl AC_SUBST(EVOLUTION_CALENDAR_CONDUIT_LIBS)
dnl --- evolution-mail flags
-dnl ******************************
-dnl Versioned library files
-dnl ******************************
-
-privlibdir='$(pkglibdir)/'$EVOLUTION_MAJOR_VERSION.$EVOLUTION_MINOR_VERSION
-AC_SUBST(privlibdir)
-
-camel_providerdir="$privlibdir/camel-providers"
-AC_SUBST(camel_providerdir)
-
EVO_SET_COMPILE_FLAGS(EVOLUTION_MAIL, libgnome-2.0 libgnomeui-2.0 libbonoboui-2.0 gal-2.0 >= $GAL_VERSION libglade-2.0 soup-2.0 libgnomeprint-2.0 libgtkhtml-3.0 libxml-2.0 bonobo-activation-2.0 gthread-2.0 gconf-2.0)
AC_SUBST(EVOLUTION_MAIL_CFLAGS)
AC_SUBST(EVOLUTION_MAIL_LIBS)
@@ -1139,6 +1115,19 @@ EVO_SET_COMPILE_FLAGS(WOMBAT, libgnome-2.0, $LDAP_CFLAGS, $LDAP_LIBS)
AC_SUBST(WOMBAT_CFLAGS)
AC_SUBST(WOMBAT_LIBS)
+dnl *******************
+dnl Special directories
+dnl *******************
+
+privlibdir='${libdir}'/evolution/`echo $VERSION | awk -F. '{print $1 "." $2;}'`
+AC_SUBST(privlibdir)
+
+camel_providerdir="$privlibdir/camel-providers"
+AC_SUBST(camel_providerdir)
+
+idldir="$datadir/idl"
+AC_SUBST(idldir)
+
##################################################
# Check for gtk-doc.
##################################################
@@ -1222,9 +1211,9 @@ fi
AM_CONDITIONAL(HAVE_KDE_APPLNK, test x"$KDE_APPLNK_DIR" != x)
AC_SUBST(KDE_APPLNK_DIR)
-dnl ******************************
-dnl foo for *Conf.sh.in
-dnl ******************************
+dnl ***********************
+dnl foo for pkgconfig files
+dnl ***********************
EVOLUTION_LIBDIR="-L${libdir}"
EVOLUTION_DATADIR="${datadir}"
@@ -1333,6 +1322,10 @@ calendar/importers/Makefile
composer/Makefile
mail/Makefile
mail/importers/Makefile
+evolution-shell.pc
+evolution-addressbook.pc
+evolution-calendar.pc
+camel.pc
])
if test "x$with_sub_version" != "x"; then