aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChris Toshok <toshok@src.gnome.org>2000-04-12 08:58:20 +0800
committerChris Toshok <toshok@src.gnome.org>2000-04-12 08:58:20 +0800
commitcce829e8a4730b293dc7fbd729b0b5775e48ba22 (patch)
tree4eae046a3d63dfd901976d2cc5b94ac0f50e0e7e /configure.in
parentbed92671a3bbbd0264fa75d54779659922b81276 (diff)
downloadgsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.gz
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.bz2
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.lz
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.xz
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.tar.zst
gsoc2013-evolution-cce829e8a4730b293dc7fbd729b0b5775e48ba22.zip
add LDAP_LIBS here.
* wombat/Makefile.am (wombat_LDADD): add LDAP_LIBS here. * configure.in: check for -lldap and -llber and if both are present include ldap support in the pas/wombat. * addressbook/backend/pas/Makefile.am (libpas_la_SOURCES): include pas-backend.ldap.c if ENABLE_LDAP. * addressbook/backend/pas/pas-backend-ldap.c: get searching working (converting between the sexp and ldap stuff.) * wombat/wombat.c (setup_pas): register the ldap pas backend if HAVE_LDAP is defined. svn path=/trunk/; revision=2401
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d057649280..8dbd3190c0 100644
--- a/configure.in
+++ b/configure.in
@@ -89,6 +89,21 @@ dnl **************************************************
AC_CHECK_HEADERS(db_185.h)
dnl **************************************************
+dnl * ldap related stuff.
+dnl **************************************************
+AC_CHECK_LIB(lber, ber_get_tag, LDAP_LIBS="-llber")
+if test $ac_cv_lib_lber_ber_get_tag = yes; then
+AC_CHECK_LIB(ldap, ldap_open, LDAP_LIBS="-lldap $LDAP_LIBS", ,-llber)
+fi
+if test $ac_cv_lib_ldap_ldap_open = yes; then
+ AC_DEFINE(HAVE_LDAP)
+ AC_SUBST(LDAP_LIBS)
+else
+ AC_MSG_WARN(no ldap support present)
+fi
+AM_CONDITIONAL(ENABLE_LDAP, test $ac_cv_lib_ldap_ldap_open = yes)
+
+dnl **************************************************
dnl * Posix thread support
dnl **************************************************