aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJP Rosevear <jpr@ximian.com>2003-10-31 21:28:44 +0800
committerJP Rosevear <jpr@src.gnome.org>2003-10-31 21:28:44 +0800
commitbdf19d320404cc3c0aa6900ea711279f80ceab6a (patch)
tree344bc87daad354aa5ae91ce9e2b9a018d137d7a8 /configure.in
parent318ff6a39433c962150b5bd78e2bd13de7b637d8 (diff)
downloadgsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.gz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.bz2
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.lz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.xz
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.tar.zst
gsoc2013-evolution-bdf19d320404cc3c0aa6900ea711279f80ceab6a.zip
set up vars and rules for versioning the .server files
2003-10-31 JP Rosevear <jpr@ximian.com> * configure.in: set up vars and rules for versioning the .server files * Makefile.am's: use rules for versioning .server file, ensure built files are removed before disting svn path=/trunk/; revision=23149
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a31f912bde..eb6f08eba6 100644
--- a/configure.in
+++ b/configure.in
@@ -1258,6 +1258,19 @@ AC_SUBST(etspecdir)
viewsdir="$privdatadir/views"
AC_SUBST(viewsdir)
+dnl ************************
+dnl IDL/Component Versioning
+dnl ************************
+
+INTERFACE_VERSION="$BASE_VERSION"
+AC_SUBST(INTERFACE_VERSION)
+AC_DEFINE_UNQUOTED(INTERFACE_VERSION, "INTERFACE_VERSION", [IDL interface version (Major.Minor)])
+
+EVO_SUBST_SERVER_RULE='%.server.in: %.server.in.in ; sed -e "s|\@BINDIR\@|$(bindir)|" -e "s|\@LIBEXECDIR\@|$(privlibexecdir)|" -e "s|\@COMPONENTDIR\@|$(componentdir)|" -e "s|\@IMPORTERSDIR\@|$(importersdir)|" -e "s|\@VERSION\@|$(BASE_VERSION)|" -e "s|\@INTERFACE_VERSION\@|$(INTERFACE_VERSION)|" $< > $@'
+EVO_NAME_SERVER_RULE='%_$(BASE_VERSION).server: %.server ; mv $< $@'
+AC_SUBST(EVO_SUBST_SERVER_RULE)
+AC_SUBST(EVO_NAME_SERVER_RULE)
+
##################################################
# Check for gtk-doc.
##################################################