aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorsimon.zheng <simon.zheng@sun.com>2006-06-12 20:52:02 +0800
committerSimon Zheng <simonz@src.gnome.org>2006-06-12 20:52:02 +0800
commitac32475e3d6ec13a7a66b1bd518aa20c122ffccc (patch)
treee4d87dabb5e315ef4bab36c1e89127167018b22b /configure.in
parent10b7d5f8704e6ba3a928f7b1418e55dd6f118bb5 (diff)
downloadgsoc2013-evolution-ac32475e3d6ec13a7a66b1bd518aa20c122ffccc.tar
gsoc2013-evolution-ac32475e3d6ec13a7a66b1bd518aa20c122ffccc.tar.gz
gsoc2013-evolution-ac32475e3d6ec13a7a66b1bd518aa20c122ffccc.tar.bz2
gsoc2013-evolution-ac32475e3d6ec13a7a66b1bd518aa20c122ffccc.tar.lz
gsoc2013-evolution-ac32475e3d6ec13a7a66b1bd518aa20c122ffccc.tar.xz
gsoc2013-evolution-ac32475e3d6ec13a7a66b1bd518aa20c122ffccc.tar.zst
gsoc2013-evolution-ac32475e3d6ec13a7a66b1bd518aa20c122ffccc.zip
Fix for #336453
2006-06-12 simon.zheng <simon.zheng@sun.com> Fix for #336453 * acinclude.m4: * configure.in: Add SunLDAP library support - a variant of Netscape LDAP. svn path=/trunk/; revision=32117
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 4ffef40616..4aace1c63c 100644
--- a/configure.in
+++ b/configure.in
@@ -444,6 +444,30 @@ msg_ldap="yes"
fi # Win32
dnl **************************************************
+dnl SunLDAP support, but if OpenLDAP support, skip check SunLDAP.
+dnl **************************************************
+if test "$with_openldap" = no ; then
+ EVO_SUNLDAP_CHECK(no)
+ case $with_sunldap in
+ no)
+ msg_ldap=no
+ ;;
+ *)
+ case $with_static_sunldap in
+ yes)
+ msg_ldap="$with_sunldap (static)"
+ ;;
+ *)
+ msg_ldap="$with_sunldap (dynamic)"
+ ;;
+ esac
+ esac
+else
+ with_sunldap=no
+fi
+AM_CONDITIONAL(SUNLDAP, test "$with_sunldap" != no)
+
+dnl **************************************************
dnl NNTP support.
dnl **************************************************
AC_ARG_ENABLE(nntp,