aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorSuman Manjunath <msuman@src.gnome.org>2008-03-17 12:24:32 +0800
committerSuman Manjunath <msuman@src.gnome.org>2008-03-17 12:24:32 +0800
commit91171e631e679e2d77e2930527d00b00700293b7 (patch)
tree40012d47738cf6c82ba4b92ec80739c9ee9ce198 /configure.in
parentfc20edb3e4b7225db03ee469843dba50aa25dbf7 (diff)
downloadgsoc2013-evolution-91171e631e679e2d77e2930527d00b00700293b7.tar
gsoc2013-evolution-91171e631e679e2d77e2930527d00b00700293b7.tar.gz
gsoc2013-evolution-91171e631e679e2d77e2930527d00b00700293b7.tar.bz2
gsoc2013-evolution-91171e631e679e2d77e2930527d00b00700293b7.tar.lz
gsoc2013-evolution-91171e631e679e2d77e2930527d00b00700293b7.tar.xz
gsoc2013-evolution-91171e631e679e2d77e2930527d00b00700293b7.tar.zst
gsoc2013-evolution-91171e631e679e2d77e2930527d00b00700293b7.zip
Patch from Paul Bolle <pebolle@tiscali.nl>: Fix for bug #519421 (Also allow <libytnef/ytnef.h> header while compiling the TNEF attachment decoder plugin)
svn path=/trunk/; revision=35206
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 34a13ea797..2a4466c795 100644
--- a/configure.in
+++ b/configure.in
@@ -1388,10 +1388,22 @@ AC_TRY_COMPILE([#include <stdio.h>
if test "$tnef_ok" = "yes"; then
AC_MSG_RESULT([yes])
TNEF_ATTACHMENTS="tnef-attachments"
+ TNEF_CFLAGS="-DHAVE_YTNEF_H"
else
- AC_MSG_RESULT(no)
- TNEF_ATTACHMENTS=""
+ AC_TRY_COMPILE([#include <stdio.h>
+ #include <libytnef/ytnef.h>],
+ [TNEFStruct *tnef;], tnef_ok=yes, tnef_ok=no)
+ if test "$tnef_ok" = "yes"; then
+ AC_MSG_RESULT([yes])
+ TNEF_ATTACHMENTS="tnef-attachments"
+ TNEF_CFLAGS="-DHAVE_LIBYTNEF_YTNEF_H"
+ else
+ AC_MSG_RESULT(no)
+ TNEF_ATTACHMENTS=""
+ TNEF_CFLAGS=""
+ fi
fi
+AC_SUBST(TNEF_CFLAGS)
echo "TNEF is "$TNEF_ATTACHMENTS