aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChris Toshok <toshok@src.gnome.org>2000-04-12 07:39:20 +0800
committerChris Toshok <toshok@src.gnome.org>2000-04-12 07:39:20 +0800
commit8a75c79c81141e7330c824f7441732d7fc158f54 (patch)
tree6ade8dd454c48b22fdb38f50ecec6e111fecaef4 /configure.in
parent215ecb48eb0a35c04315d67854a7daaf2026378d (diff)
downloadgsoc2013-evolution-8a75c79c81141e7330c824f7441732d7fc158f54.tar
gsoc2013-evolution-8a75c79c81141e7330c824f7441732d7fc158f54.tar.gz
gsoc2013-evolution-8a75c79c81141e7330c824f7441732d7fc158f54.tar.bz2
gsoc2013-evolution-8a75c79c81141e7330c824f7441732d7fc158f54.tar.lz
gsoc2013-evolution-8a75c79c81141e7330c824f7441732d7fc158f54.tar.xz
gsoc2013-evolution-8a75c79c81141e7330c824f7441732d7fc158f54.tar.zst
gsoc2013-evolution-8a75c79c81141e7330c824f7441732d7fc158f54.zip
check for timezone as a variable (as it is in linux, but not in freebsd or
* configure.in: check for timezone as a variable (as it is in linux, but not in freebsd or netbsd.) svn path=/trunk/; revision=2398
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 5fed2fd6e1..e78011ef95 100644
--- a/configure.in
+++ b/configure.in
@@ -55,6 +55,30 @@ AM_GNOME_GETTEXT
GNOME_X_CHECKS
+dnl * Time zone stuff
+AC_CACHE_CHECK(for timezone variable, ac_cv_var_timezone,
+ AC_TRY_COMPILE([
+ #include <time.h>
+ ], [
+ timezone = 1;
+ ], ac_cv_var_timezone=yes, ac_cv_var_timezone=no))
+if test $ac_cv_var_timezone = yes; then
+ AC_DEFUN(HAVE_TIMEZONE)
+else
+ AC_CACHE_CHECK(for tm_gmtoff in struct tm, ac_cv_struct_tm_gmtoff,
+ AC_TRY_COMPILE([
+ #include <time.h>
+ ], [
+ struct tm tm;
+ tm.tm_gmtoff = 1;
+ ], ac_cv_struct_tm_gmtoff=yes, ac_cv_struct_tm_gmtoff=no))
+ if test $ac_cv_struct_tm_gmtoff = yes; then
+ AC_DEFUN(HAVE_TM_GMTOFF)
+ else
+ AC_ERROR(unable to find a way to determine timezone)
+ fi
+fi
+
AC_CHECK_FUNCS(mkstemp)
dnl **************************************************
@@ -272,6 +296,7 @@ camel/providers/Makefile
camel/providers/MH/Makefile
camel/providers/maildir/Makefile
camel/providers/mbox/Makefile
+camel/providers/nntp/Makefile
camel/providers/pop3/Makefile
camel/providers/sendmail/Makefile
camel/providers/smtp/Makefile