aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMiguel de Icaza <miguel@nuclecu.unam.mx>2000-02-19 01:53:53 +0800
committerMiguel de Icaza <miguel@src.gnome.org>2000-02-19 01:53:53 +0800
commit85daf8e5a6b9155c34d6231190594cf96dd8d5c3 (patch)
tree692898d467b9a42d25b001dfa3a5a9b6cbdec9cc /configure.in
parent3e317e1b1776d0cd505aaba4a446899af8798eaa (diff)
downloadgsoc2013-evolution-85daf8e5a6b9155c34d6231190594cf96dd8d5c3.tar
gsoc2013-evolution-85daf8e5a6b9155c34d6231190594cf96dd8d5c3.tar.gz
gsoc2013-evolution-85daf8e5a6b9155c34d6231190594cf96dd8d5c3.tar.bz2
gsoc2013-evolution-85daf8e5a6b9155c34d6231190594cf96dd8d5c3.tar.lz
gsoc2013-evolution-85daf8e5a6b9155c34d6231190594cf96dd8d5c3.tar.xz
gsoc2013-evolution-85daf8e5a6b9155c34d6231190594cf96dd8d5c3.tar.zst
gsoc2013-evolution-85daf8e5a6b9155c34d6231190594cf96dd8d5c3.zip
Use the new method for gnome-print checking instead of the old crufty gtk+
2000-02-18 Miguel de Icaza <miguel@nuclecu.unam.mx> * configure.in (have_pthread): Use the new method for gnome-print checking instead of the old crufty gtk+ based one that nobody can svn path=/trunk/; revision=1839
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f0e5d704fe..8f3bf12ec1 100644
--- a/configure.in
+++ b/configure.in
@@ -65,7 +65,18 @@ AM_CONDITIONAL(ENABLE_THREADS, $have_pthread)
dnl **************************************************
dnl * Print check
dnl **************************************************
-GNOME_PRINT_CHECK
+AC_MSG_CHECKING(for GnomePrint libraries >= 0.10)
+if gnome-config --libs print > /dev/null 2>&1; then
+ vers=`gnome-config --modversion print | sed -e "s/gnome-print-//" | \
+ awk 'BEGIN { FS = "."; } { print $1 * 1000 + $2;}'`
+ if test "$vers" -ge 10; then
+ AC_MSG_RESULT(found)
+ else
+ AC_MSG_ERROR(You need at least GNOME print 0.10 for this version of Gnumeric)
+ fi
+else
+ AC_MSG_ERROR(Did not find GnomePrint installed)
+fi
dnl **************************************************
dnl * ORBit support