aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJeffrey Stedfast <fejj@ximian.com>2001-09-05 01:57:30 +0800
committerJeffrey Stedfast <fejj@src.gnome.org>2001-09-05 01:57:30 +0800
commit6fe406c265839de855b35abbad54b3ed63d07ba1 (patch)
tree4117b71f02991b74cbfd3a158b9c694b574a8e1d /configure.in
parentcc790d8c6f597ab93a42ad6a022b29f71179371d (diff)
downloadgsoc2013-evolution-6fe406c265839de855b35abbad54b3ed63d07ba1.tar
gsoc2013-evolution-6fe406c265839de855b35abbad54b3ed63d07ba1.tar.gz
gsoc2013-evolution-6fe406c265839de855b35abbad54b3ed63d07ba1.tar.bz2
gsoc2013-evolution-6fe406c265839de855b35abbad54b3ed63d07ba1.tar.lz
gsoc2013-evolution-6fe406c265839de855b35abbad54b3ed63d07ba1.tar.xz
gsoc2013-evolution-6fe406c265839de855b35abbad54b3ed63d07ba1.tar.zst
gsoc2013-evolution-6fe406c265839de855b35abbad54b3ed63d07ba1.zip
Only check for OpenSSL if we were not able to find Mozilla's NSS
2001-09-04 Jeffrey Stedfast <fejj@ximian.com> * configure.in: Only check for OpenSSL if we were not able to find Mozilla's NSS libraries. svn path=/trunk/; revision=12588
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in122
1 files changed, 62 insertions, 60 deletions
diff --git a/configure.in b/configure.in
index 7f17e18e64..5c6e72ae85 100644
--- a/configure.in
+++ b/configure.in
@@ -755,14 +755,14 @@ AC_SUBST(KRB4_CFLAGS)
AC_SUBST(KRB4_LDFLAGS)
-dnl ===============================================================================
-dnl = security extension support (SSL and S/MIME)
-dnl =
-dnl = The following voodoo does detection of mozilla libraries (nspr and nss)
-dnl = needed by Camel (SSL) and Evolution (S/MIME).
-dnl =
-dnl = The Evolution security extensions are only built if these libraries are found
-dnl ===============================================================================
+dnl ********************************************************************************
+dnl security extension support (SSL and S/MIME)
+dnl
+dnl The following voodoo does detection of mozilla libraries (nspr and nss)
+dnl needed by Camel (SSL and S/MIME).
+dnl
+dnl The Evolution security extensions are only built if these libraries are found
+dnl ********************************************************************************
AC_ARG_WITH(nspr-includes, [ --with-nspr-includes=PREFIX Location of Mozilla nspr4 includes.],
with_nspr_includes="$withval", with_nspr_includes="/usr/include/mozilla")
have_nspr_includes="no"
@@ -883,69 +883,71 @@ AC_SUBST(NSPR_LDFLAGS)
AC_SUBST(NSS_CFLAGS)
AC_SUBST(NSS_LDFLAGS)
-dnl ====================================
-dnl = End mozilla hacks
-dnl ====================================
-
dnl ******************************
dnl OpenSSL
dnl ******************************
-AC_ARG_WITH(openssl-includes, [ --with-openssl-includes=PREFIX Location of OpenSSL includes.],
- with_openssl_includes="$withval", with_openssl_includes="/usr/include")
-have_openssl_includes="no"
-if test "x${with_openssl_includes}" != "xno"; then
- CPPFLAGS_save="$CPPFLAGS"
+if test "x${msg_nss}" != "xyes"; then
+ AC_ARG_WITH(openssl-includes, [ --with-openssl-includes=PREFIX Location of OpenSSL includes.],
+ with_openssl_includes="$withval", with_openssl_includes="/usr/include")
+ have_openssl_includes="no"
+ if test "x${with_openssl_includes}" != "xno"; then
+ CPPFLAGS_save="$CPPFLAGS"
+
+ AC_MSG_CHECKING(for OpenSSL includes)
+ AC_MSG_RESULT("")
+
+ CPPFLAGS="$CPPFLAGS -I$with_openssl_includes"
+ AC_CHECK_HEADERS(openssl/ssl.h openssl/x509.h, [ openssl_includes="yes" ])
+ CPPFLAGS="$CPPFLAGS_save"
+
+ if test "x{$openssl_includes}" != "xno" -a "x{$openssl_includes}" != "x"; then
+ have_openssl_includes="yes"
+ OPENSSL_CFLAGS="-I$with_openssl_includes"
+ else
+ OPENSSL_CFLAGS=""
+ fi
+ else
+ AC_MSG_CHECKING(for OpenSSL includes)
+ AC_MSG_RESULT(no)
+ fi
- AC_MSG_CHECKING(for OpenSSL includes)
- AC_MSG_RESULT("")
+ AC_ARG_WITH(openssl-libs, [ --with-openssl-libs=PREFIX Location of OpenSSL libs.],
+ with_openssl_libs="$withval")
+ msg_openssl="no"
+ if test "x${with_openssl_libs}" != "xno" -a "x${have_openssl_includes}" != "xno"; then
+ LDFLAGS_save="$LDFLAGS"
- CPPFLAGS="$CPPFLAGS -I$with_openssl_includes"
- AC_CHECK_HEADERS(openssl/ssl.h openssl/x509.h, [ openssl_includes="yes" ])
- CPPFLAGS="$CPPFLAGS_save"
+ case $with_openssl_libs in
+ ""|-L*) ;;
+ *) $with_openssl_libs="-L$with_openssl_libs" ;;
+ esac
- if test "x{$openssl_includes}" != "xno" -a "x{$openssl_includes}" != "x"; then
- have_openssl_includes="yes"
- OPENSSL_CFLAGS="-I$with_openssl_includes"
- else
- OPENSSL_CFLAGS=""
- fi
-else
- AC_MSG_CHECKING(for OpenSSL includes)
- AC_MSG_RESULT(no)
-fi
-
-AC_ARG_WITH(openssl-libs, [ --with-openssl-libs=PREFIX Location of OpenSSL libs.],
- with_openssl_libs="$withval")
-msg_openssl="no"
-if test "x${with_openssl_libs}" != "xno" -a "x${have_openssl_includes}" != "xno"; then
- LDFLAGS_save="$LDFLAGS"
-
- case $with_openssl_libs in
- ""|-L*) ;;
- *) $with_openssl_libs="-L$with_openssl_libs" ;;
- esac
-
- AC_CHECK_LIB(dl, dlopen, DL_LDFLAGS="-ldl", DL_LDFLAGS="")
- AC_CACHE_CHECK([for OpenSSL libraries], openssl_libs,
- [
- LDFLAGS="$LDFLAGS $with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
- AC_TRY_LINK_FUNC(SSL_read, openssl_libs="yes", openssl_libs="no")
- LDFLAGS="$LDFLAGS_save"
- ])
- if test "x${openssl_libs}" != "xno"; then
- AC_DEFINE(HAVE_OPENSSL)
- msg_openssl="yes"
- OPENSSL_LDFLAGS="$with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
+ AC_CHECK_LIB(dl, dlopen, DL_LDFLAGS="-ldl", DL_LDFLAGS="")
+ AC_CACHE_CHECK([for OpenSSL libraries], openssl_libs,
+ [
+ LDFLAGS="$LDFLAGS $with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
+ AC_TRY_LINK_FUNC(SSL_read, openssl_libs="yes", openssl_libs="no")
+ LDFLAGS="$LDFLAGS_save"
+ ])
+ if test "x${openssl_libs}" != "xno"; then
+ AC_DEFINE(HAVE_OPENSSL)
+ msg_openssl="yes"
+ OPENSSL_LDFLAGS="$with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
+ else
+ OPENSSL_CFLAGS=""
+ OPENSSL_LDFLAGS=""
+ fi
else
- OPENSSL_CFLAGS=""
- OPENSSL_LDFLAGS=""
+ AC_MSG_CHECKING(for OpenSSL libraries)
+ AC_MSG_RESULT(no)
fi
else
- AC_MSG_CHECKING(for OpenSSL libraries)
- AC_MSG_RESULT(no)
+ OPENSSL_CFLAGS=""
+ OPENSSL_LDFLAGS=""
+ msg_openssl="no"
fi
-
+
AC_SUBST(OPENSSL_CFLAGS)
AC_SUBST(OPENSSL_LDFLAGS)