aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTor Lillqvist <tml@novell.com>2005-09-28 16:55:59 +0800
committerTor Lillqvist <tml@src.gnome.org>2005-09-28 16:55:59 +0800
commit665105ab1052fe36ddc742747ff541fdfdae49a5 (patch)
treeb22f156b8d85e6d71ebe1b3160a4ddd99385c831 /configure.in
parent4276d74d2713f8b835bc7db8e0e9f92b7e10fdbc (diff)
downloadgsoc2013-evolution-665105ab1052fe36ddc742747ff541fdfdae49a5.tar
gsoc2013-evolution-665105ab1052fe36ddc742747ff541fdfdae49a5.tar.gz
gsoc2013-evolution-665105ab1052fe36ddc742747ff541fdfdae49a5.tar.bz2
gsoc2013-evolution-665105ab1052fe36ddc742747ff541fdfdae49a5.tar.lz
gsoc2013-evolution-665105ab1052fe36ddc742747ff541fdfdae49a5.tar.xz
gsoc2013-evolution-665105ab1052fe36ddc742747ff541fdfdae49a5.tar.zst
gsoc2013-evolution-665105ab1052fe36ddc742747ff541fdfdae49a5.zip
Drop unused SOCKET_LIBS leftover. Don't check for OpenLDAP on Win32. Set
2005-09-28 Tor Lillqvist <tml@novell.com> * configure.in: Drop unused SOCKET_LIBS leftover. Don't check for OpenLDAP on Win32. Set corresponding variables unconditionally on Win32, as LDAP support is always present (in <winldap.h> and -lwldap32). (CAMEL_EXCHANGE): Add more stuff to CAMEL_EXCHANGE_CFLAGS and _LIBS. These are used only in plugins/exchange-operations/Makefile.am, and now it's enough to use only that CAMEL_EXCHANGE_CFLAGS and _LIBS there. In plugins/exchange-operations: 2005-09-28 Tor Lillqvist <tml@novell.com> * Makefile.am (INCLUDES, LIBADD): Use just CAMEL_EXCHANGE_CFLAGS and _LIBS, they now includes all necessary (see top-level ChangeLog). (LDFLAGS): Use NO_UNDEFINED. svn path=/trunk/; revision=30388
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5d422ed96c..e44a75397b 100644
--- a/configure.in
+++ b/configure.in
@@ -106,7 +106,6 @@ case "$host" in
;;
*) os_win32=no
NO_UNDEFINED=''
- SOCKET_LIBS=''
SOEXT='.so'
SA_JUNK_PLUGIN=sa-junk-plugin
DL_LIB='-ldl'
@@ -462,6 +461,7 @@ AM_CONDITIONAL(ENABLE_IPv6, test "x$enable_ipv6" = "xyes")
dnl **************************************************
dnl LDAP support.
dnl **************************************************
+if test "$os_win32" != yes; then
EVO_LDAP_CHECK(no)
case $with_openldap in
no)
@@ -477,6 +477,15 @@ no)
;;
esac
esac
+else # Win32
+LDAP_CFLAGS=""
+LDAP_LIBS="-lwldap32"
+AC_SUBST(LDAP_CFLAGS)
+AC_SUBST(LDAP_LIBS)
+AC_DEFINE(HAVE_LDAP,1,[Define if you have LDAP support])
+AM_CONDITIONAL(ENABLE_LDAP, true)
+msg_exchange="yes"
+fi # Win32
dnl **************************************************
dnl NNTP support.
@@ -1500,7 +1509,7 @@ if echo ${plugins_enabled} | grep "exchange-operations" > /dev/null ; then
dnl **************************************************
dnl * Exchange Operations plugin
dnl **************************************************
- EVO_SET_COMPILE_FLAGS(CAMEL_EXCHANGE, camel-provider-$EDS_PACKAGE libedataserver-$EDS_PACKAGE libexchange-storage-$EDS_PACKAGE >= $EDS_REQUIRED)
+ EVO_SET_COMPILE_FLAGS(CAMEL_EXCHANGE, libbonoboui-2.0 >= $BONOBOUI_REQUIRED libglade-2.0 libgnomeprint-2.2 libgnomeprintui-2.2 gthread-2.0 gconf-2.0 camel-provider-$EDS_PACKAGE libebook-$EDS_PACKAGE >= $EDS_REQUIRED libedataserverui-$EDS_PACKAGE libexchange-storage-$EDS_PACKAGE >= $EDS_REQUIRED libecal-$EDS_PACKAGE)
AC_SUBST(CAMEL_EXCHANGE_CFLAGS)
AC_SUBST(CAMEL_EXCHANGE_LIBS)
else