aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRodney Dawes <dobey@ximian.com>2004-01-29 05:42:19 +0800
committerRodney Dawes <dobey@src.gnome.org>2004-01-29 05:42:19 +0800
commit5ffd488adbe5ce87ded0d2d5775eb04e45200237 (patch)
tree658684b3cbae1670cb554afba59216cf70540b5a /configure.in
parent3af02b087f634b58514f4ae159cb04b826cbc99a (diff)
downloadgsoc2013-evolution-5ffd488adbe5ce87ded0d2d5775eb04e45200237.tar
gsoc2013-evolution-5ffd488adbe5ce87ded0d2d5775eb04e45200237.tar.gz
gsoc2013-evolution-5ffd488adbe5ce87ded0d2d5775eb04e45200237.tar.bz2
gsoc2013-evolution-5ffd488adbe5ce87ded0d2d5775eb04e45200237.tar.lz
gsoc2013-evolution-5ffd488adbe5ce87ded0d2d5775eb04e45200237.tar.xz
gsoc2013-evolution-5ffd488adbe5ce87ded0d2d5775eb04e45200237.tar.zst
gsoc2013-evolution-5ffd488adbe5ce87ded0d2d5775eb04e45200237.zip
Disable the possibility of using OpenSSL until someone decides it is
2004-01-28 Rodney Dawes <dobey@ximian.com> * configure.in: Disable the possibility of using OpenSSL until someone decides it is worthy and ends up maintaining the code, though porting to GNUTLS would probably be a better option, if that happens svn path=/trunk/; revision=24501
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in138
1 files changed, 69 insertions, 69 deletions
diff --git a/configure.in b/configure.in
index 97fa99ffbf..860905eaaa 100644
--- a/configure.in
+++ b/configure.in
@@ -611,14 +611,14 @@ dnl these 2 enable's are inverses of each other
AC_ARG_ENABLE(nss, [ --enable-nss=[yes,no,static] Attempt to use Mozilla libnss for SSL support.],
enable_nss="$enableval", enable_nss="yes")
-AC_ARG_ENABLE(openssl, [ --enable-openssl=[no,yes] Attempt to use OpenSSL for SSL support.],
- enable_openssl="$enableval", enable_openssl="no")
-
-if test "x${enable_openssl}" = "xyes"; then
+dnl AC_ARG_ENABLE(openssl, [ --enable-openssl=[no,yes] Attempt to use OpenSSL for SSL support.],
+dnl enable_openssl="$enableval", enable_openssl="no")
+dnl
+dnl if test "x${enable_openssl}" = "xyes"; then
dnl User wants to override nss with OpenSSL
- enable_nss="no"
- AC_MSG_WARN([OpenSSL enabled, disabling NSS.])
-fi
+dnl enable_nss="no"
+dnl AC_MSG_WARN([OpenSSL enabled, disabling NSS.])
+dnl fi
AC_ARG_WITH(nspr-includes, [ --with-nspr-includes=PREFIX Location of Mozilla nspr4 includes.],
with_nspr_includes="$withval")
@@ -871,68 +871,68 @@ dnl ******************************
dnl only continue detecting OpenSSL if we haven't already found all of the
dnl Mozilla libnss includes/libraries and if user actually wants ssl support
-if test "$msg_ssl" = "no" -a "x${enable_openssl}" != "xno"; then
- AC_ARG_WITH(openssl-includes, [ --with-openssl-includes=PREFIX Location of OpenSSL includes.],
- with_openssl_includes="$withval", with_openssl_includes="/usr/include")
- have_openssl_includes="no"
- if test "x${with_openssl_includes}" != "xno"; then
- CPPFLAGS_save="$CPPFLAGS"
-
- AC_MSG_CHECKING(for OpenSSL includes)
- AC_MSG_RESULT("")
-
- CPPFLAGS="$CPPFLAGS -I$with_openssl_includes"
- AC_CHECK_HEADERS(openssl/ssl.h openssl/x509.h, [ openssl_includes="yes" ])
- CPPFLAGS="$CPPFLAGS_save"
-
- if test "x{$openssl_includes}" != "xno" -a "x{$openssl_includes}" != "x"; then
- have_openssl_includes="yes"
- OPENSSL_CFLAGS="-I$with_openssl_includes"
- else
- OPENSSL_CFLAGS=""
- fi
- else
- AC_MSG_CHECKING(for OpenSSL includes)
- AC_MSG_RESULT(no)
- fi
-
- AC_ARG_WITH(openssl-libs, [ --with-openssl-libs=PREFIX Location of OpenSSL libs.],
- with_openssl_libs="$withval")
- if test "x${with_openssl_libs}" != "xno" -a "x${have_openssl_includes}" != "xno"; then
- LDFLAGS_save="$LDFLAGS"
-
- case $with_openssl_libs in
- ""|-L*) ;;
- *) with_openssl_libs="-L$with_openssl_libs" ;;
- esac
-
- AC_CHECK_LIB(dl, dlopen, DL_LDFLAGS="-ldl", DL_LDFLAGS="")
- AC_CACHE_CHECK([for OpenSSL libraries], openssl_libs,
- [
- LDFLAGS="$LDFLAGS $with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
- AC_TRY_LINK_FUNC(SSL_read, openssl_libs="yes", openssl_libs="no")
- LDFLAGS="$LDFLAGS_save"
- ])
- if test "x${openssl_libs}" != "xno"; then
- AC_DEFINE(HAVE_OPENSSL,1,[Define if you have OpenSSL])
- AC_DEFINE(HAVE_SSL)
- msg_ssl="yes (OpenSSL)"
- OPENSSL_LDFLAGS="$with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
- else
- OPENSSL_CFLAGS=""
- OPENSSL_LDFLAGS=""
- fi
- else
- AC_MSG_CHECKING(for OpenSSL libraries)
- AC_MSG_RESULT(no)
- fi
-else
- OPENSSL_CFLAGS=""
- OPENSSL_LDFLAGS=""
-fi
-
-AC_SUBST(OPENSSL_CFLAGS)
-AC_SUBST(OPENSSL_LDFLAGS)
+dnl if test "$msg_ssl" = "no" -a "x${enable_openssl}" != "xno"; then
+dnl AC_ARG_WITH(openssl-includes, [ --with-openssl-includes=PREFIX Location of OpenSSL includes.],
+dnl with_openssl_includes="$withval", with_openssl_includes="/usr/include")
+dnl have_openssl_includes="no"
+dnl if test "x${with_openssl_includes}" != "xno"; then
+dnl CPPFLAGS_save="$CPPFLAGS"
+dnl
+dnl AC_MSG_CHECKING(for OpenSSL includes)
+dnl AC_MSG_RESULT("")
+dnl
+dnl CPPFLAGS="$CPPFLAGS -I$with_openssl_includes"
+dnl AC_CHECK_HEADERS(openssl/ssl.h openssl/x509.h, [ openssl_includes="yes" ])
+dnl CPPFLAGS="$CPPFLAGS_save"
+dnl
+dnl if test "x{$openssl_includes}" != "xno" -a "x{$openssl_includes}" != "x"; then
+dnl have_openssl_includes="yes"
+dnl OPENSSL_CFLAGS="-I$with_openssl_includes"
+dnl else
+dnl OPENSSL_CFLAGS=""
+dnl fi
+dnl else
+dnl AC_MSG_CHECKING(for OpenSSL includes)
+dnl AC_MSG_RESULT(no)
+dnl fi
+dnl
+dnl AC_ARG_WITH(openssl-libs, [ --with-openssl-libs=PREFIX Location of OpenSSL libs.],
+dnl with_openssl_libs="$withval")
+dnl if test "x${with_openssl_libs}" != "xno" -a "x${have_openssl_includes}" != "xno"; then
+dnl LDFLAGS_save="$LDFLAGS"
+dnl
+dnl case $with_openssl_libs in
+dnl ""|-L*) ;;
+dnl *) with_openssl_libs="-L$with_openssl_libs" ;;
+dnl esac
+dnl
+dnl AC_CHECK_LIB(dl, dlopen, DL_LDFLAGS="-ldl", DL_LDFLAGS="")
+dnl AC_CACHE_CHECK([for OpenSSL libraries], openssl_libs,
+dnl [
+dnl LDFLAGS="$LDFLAGS $with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
+dnl AC_TRY_LINK_FUNC(SSL_read, openssl_libs="yes", openssl_libs="no")
+dnl LDFLAGS="$LDFLAGS_save"
+dnl ])
+dnl if test "x${openssl_libs}" != "xno"; then
+dnl AC_DEFINE(HAVE_OPENSSL,1,[Define if you have OpenSSL])
+dnl AC_DEFINE(HAVE_SSL)
+dnl msg_ssl="yes (OpenSSL)"
+dnl OPENSSL_LDFLAGS="$with_openssl_libs -lssl -lcrypto $DL_LDFLAGS"
+dnl else
+dnl OPENSSL_CFLAGS=""
+dnl OPENSSL_LDFLAGS=""
+dnl fi
+dnl else
+dnl AC_MSG_CHECKING(for OpenSSL libraries)
+dnl AC_MSG_RESULT(no)
+dnl fi
+dnl else
+dnl OPENSSL_CFLAGS=""
+dnl OPENSSL_LDFLAGS=""
+dnl
+dnl
+dnl AC_SUBST(OPENSSL_CFLAGS)
+dnl AC_SUBST(OPENSSL_LDFLAGS)
dnl *******************
dnl GObject marshalling