aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMilan Crha <mcrha@redhat.com>2008-07-22 16:43:06 +0800
committerMilan Crha <mcrha@src.gnome.org>2008-07-22 16:43:06 +0800
commit5e4b6fcb89797b533b9a741c491ec592d2a06721 (patch)
tree012b019d2cb42765d3bcb818093e094d020f2104 /configure.in
parent2de8babf9a0cb55073d8cd6fd7252d0df20d7946 (diff)
downloadgsoc2013-evolution-5e4b6fcb89797b533b9a741c491ec592d2a06721.tar
gsoc2013-evolution-5e4b6fcb89797b533b9a741c491ec592d2a06721.tar.gz
gsoc2013-evolution-5e4b6fcb89797b533b9a741c491ec592d2a06721.tar.bz2
gsoc2013-evolution-5e4b6fcb89797b533b9a741c491ec592d2a06721.tar.lz
gsoc2013-evolution-5e4b6fcb89797b533b9a741c491ec592d2a06721.tar.xz
gsoc2013-evolution-5e4b6fcb89797b533b9a741c491ec592d2a06721.tar.zst
gsoc2013-evolution-5e4b6fcb89797b533b9a741c491ec592d2a06721.zip
** Fix for bug #544022
2008-07-22 Milan Crha <mcrha@redhat.com> ** Fix for bug #544022 * configure.in: Do not redefine DBUS_VERSION define supplied by dbus itself, rather rename our define to FOUND_DBUS_VERSION. * mail/e-searching-tokenizer.c: (dump_trie): Define function only when required. (Compiler warning cleanup.) * shell/e-shell-window-commands.c: (char *authors[]): Break the escape sequence properly (compiler warning cleanup). * plugins/email-custom-header/email-custom-header.c: Compiler warning cleanup. * plugins/mail-notification/Makefile.am: * plugins/mail-notification/mail-notification.c: (send_dbus_message): Do not redefine DBUS_VERSION define, it's supplied by dbus itself. svn path=/trunk/; revision=35819
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index fbe677ec9c..37ea0e5704 100644
--- a/configure.in
+++ b/configure.in
@@ -1824,8 +1824,8 @@ if ${PKG_CONFIG} --exists dbus-glib-1 ; then
# Get the version of the DBus API, so we can hack around API changes until the API stabilises:
# multiply by 1000 to convert decimal to integer; so e.g. 0.31 become 310
# since preprocessor values must be integral
- DBUS_VERSION="`$PKG_CONFIG --modversion dbus-1 | $AWK '{print 1000 * $1}'`"
- AC_SUBST(DBUS_VERSION)
+ FOUND_DBUS_VERSION="`$PKG_CONFIG --modversion dbus-1 | $AWK '{print 1000 * $1}'`"
+ AC_SUBST(FOUND_DBUS_VERSION)
AC_DEFINE(HAVE_DBUS,1,[Define if you have DBUS support])
AC_SUBST(HAVE_DBUS)
AM_CONDITIONAL(ENABLE_DBUS, true)
@@ -2081,6 +2081,6 @@ echo "\
SSL support: $msg_ssl
SMIME support: $msg_smime
Plugins: $msg_plugins
- DBus API version: $DBUS_VERSION
+ DBus API version: $FOUND_DBUS_VERSION
User documentation: $with_help
"