aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDan Winship <danw@src.gnome.org>2000-05-03 09:07:17 +0800
committerDan Winship <danw@src.gnome.org>2000-05-03 09:07:17 +0800
commit56fb12bf9db2c87d4a3b075777fd2f60346aea1a (patch)
tree37c03afc4d002e3621117464be43173a2d27581b /configure.in
parentd37d28ddf27f9998a96e5b3fe12c3ffc048799f2 (diff)
downloadgsoc2013-evolution-56fb12bf9db2c87d4a3b075777fd2f60346aea1a.tar
gsoc2013-evolution-56fb12bf9db2c87d4a3b075777fd2f60346aea1a.tar.gz
gsoc2013-evolution-56fb12bf9db2c87d4a3b075777fd2f60346aea1a.tar.bz2
gsoc2013-evolution-56fb12bf9db2c87d4a3b075777fd2f60346aea1a.tar.lz
gsoc2013-evolution-56fb12bf9db2c87d4a3b075777fd2f60346aea1a.tar.xz
gsoc2013-evolution-56fb12bf9db2c87d4a3b075777fd2f60346aea1a.tar.zst
gsoc2013-evolution-56fb12bf9db2c87d4a3b075777fd2f60346aea1a.zip
add some minimal Kerberos checking. This isn't intended to be generically
* configure.in, acconfig.h: add some minimal Kerberos checking. This isn't intended to be generically useful at this point, it's just there to give me a second POP auth mechanism to play with. Also remove a bit of cruft, and reorganize configure.in a bit. svn path=/trunk/; revision=2765
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in65
1 files changed, 46 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 2967320752..8db2253bdc 100644
--- a/configure.in
+++ b/configure.in
@@ -109,7 +109,7 @@ dnl **************************************************
have_pthread=false
-AC_ARG_WITH(threads, [--with-threads include threads support],[
+AC_ARG_WITH(threads, [ --with-threads Include thread support],[
if test x$withval = xyes; then
test_thread=true
else
@@ -132,6 +132,18 @@ fi
AM_CONDITIONAL(ENABLE_THREADS, $have_pthread)
+dnl
+dnl Notice that this is a hack, and we wont be able to use this forever, but
+dnl at least for some time
+dnl
+if $have_pthread; then
+ THREADS_LIBS="$PTHREAD_LIB `glib-config --libs gthread`"
+ THREADS_CFLAGS="`glib-config --cflags gthread`"
+else
+ THREADS_LIBS=""
+ THREADS_CFLAGS=""
+fi
+
dnl **************************************************
dnl * Print check
@@ -217,18 +229,6 @@ else
AC_MSG_ERROR(Did not find gdkpixbuf installed)
fi
-dnl
-dnl Notice that this is a hack, and we wont be able to use this forever, but
-dnl at least for some time
-dnl
-if $have_pthread; then
- THREADS_LIBS="$PTHREAD_LIB `glib-config --libs gthread`"
- THREADS_CFLAGS="`glib-config --cflags gthread`"
-else
- THREADS_LIBS=""
- THREADS_CFLAGS=""
-fi
-
GLIB_CFLAGS="`glib-config --cflags`"
GLIB_LIBS="`glib-config --libs`"
@@ -315,12 +315,6 @@ if test "$xmlmajor" -ne 1 -o "$xmlminor" -ne 8 -o "$xmlpatch" -lt 7; then
AC_MSG_ERROR(gnome-xml 1.8.7 (or later, but not 2.0) is required to compile Evolution)
fi
-AC_ARG_WITH(camel-hard-log-level, [ --with-camel-hard-log-level=level value of log level in camel (0-10)],
- camel_hard_log_level="$withval", camel_hard_log_level="0")
-AC_DEFINE_UNQUOTED(CAMEL_HARD_LOG_LEVEL, $camel_hard_log_level)
-
-AC_CONFIG_SUBDIRS(libical)
-
AC_SUBST(CAPPLET_LIBS)
dnl ******************************
@@ -362,10 +356,43 @@ if test "x$enable_oaf" = "xyes"; then
BONOBO_GNOME_CFLAGS="`oaf-config --cflags ` $BONOBO_GNOME_CFLAGS"
fi
+dnl ********
+dnl Kerberos
+dnl ********
+AC_ARG_WITH(krb5, [ --with-krb5=PREFIX Location of Kerberos 5 libs/includes])
+AC_ARG_WITH(krb4, [ --with-krb4=PREFIX Location of Kerberos 4 libs/includes])
+AC_MSG_CHECKING(for Kerberos 5)
+AC_MSG_RESULT($with_krb5)
+if test x$with_krb5 != xno; then
+ KRB5_CFLAGS="-I$with_krb5/include/krb5"
+ KRB5_LDFLAGS="-L$with_krb5/lib -lkrb5 -lk5crypto -lcom_err"
+ AC_DEFINE(HAVE_KRB5)
+fi
+AC_MSG_CHECKING(for Kerberos 4)
+AC_MSG_RESULT($with_krb4)
+if test x$with_krb4 != xno; then
+ KRB4_CFLAGS="-I$with_krb4/include -I$with_krb4/include/kerberosIV $KRB5_CFLAGS"
+ save_LDFLAGS="$LDFLAGS"
+ LDFLAGS="$LDFLAGS -L$with_krb4/lib"
+ AC_CHECK_LIB(krb, krb_mk_req,
+ [KRB4_LDFLAGS="-L$with_krb4/lib -lkrb -ldes"],
+ [KRB4_LDFLAGS="-L$with_krb4/lib -lkrb4 -ldes425 -lkrb5 -lk5crypto -lcom_err"],
+ -ldes)
+ LDFLAGS="$save_LDFLAGS"
+ AC_DEFINE(HAVE_KRB4)
+fi
+AC_SUBST(KRB5_CFLAGS)
+AC_SUBST(KRB5_LDFLAGS)
+AC_SUBST(KRB4_CFLAGS)
+AC_SUBST(KRB4_LDFLAGS)
+
+
dnl ******************************
dnl Makefiles
dnl ******************************
+AC_CONFIG_SUBDIRS(libical)
+
AC_OUTPUT([
Makefile
macros/Makefile