aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMatthew Barnes <mbarnes@redhat.com>2008-11-08 01:11:10 +0800
committerMatthew Barnes <mbarnes@src.gnome.org>2008-11-08 01:11:10 +0800
commit39f06164edde0443b23baf6aea29edf5974ea868 (patch)
tree0fb8d386923ad0aa89a9b6712d1876a4092c7e09 /configure.in
parent93f24c38ae89c207e60a2af2c2eb6639d26a1372 (diff)
downloadgsoc2013-evolution-39f06164edde0443b23baf6aea29edf5974ea868.tar
gsoc2013-evolution-39f06164edde0443b23baf6aea29edf5974ea868.tar.gz
gsoc2013-evolution-39f06164edde0443b23baf6aea29edf5974ea868.tar.bz2
gsoc2013-evolution-39f06164edde0443b23baf6aea29edf5974ea868.tar.lz
gsoc2013-evolution-39f06164edde0443b23baf6aea29edf5974ea868.tar.xz
gsoc2013-evolution-39f06164edde0443b23baf6aea29edf5974ea868.tar.zst
gsoc2013-evolution-39f06164edde0443b23baf6aea29edf5974ea868.zip
** Fixes bug #557581
2008-11-07 Matthew Barnes <mbarnes@redhat.com> ** Fixes bug #557581 * configure.in: Break up the version definitions such that we can calculate the latest stable version and pass a STABLE_VERSION definition to shell/main.c. * shell/main.c: Replace DEVELOPMENT with STABLE_VERSION, which actually defines the latest stable version (e.g. 2.24). STABLE_VERSION is only defined if the current version is _unstable_ (e.g. 2.25). * shell/main.c (show_development_warning): Use STABLE_VERSION instead of hard-coding the version number. svn path=/trunk/; revision=36761
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in27
1 files changed, 16 insertions, 11 deletions
diff --git a/configure.in b/configure.in
index 9a88caaf5a..bcca179425 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,17 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.52)
-AC_INIT(evolution, 2.25.2, http://bugzilla.gnome.org/enter_bug.cgi?product=Evolution)
+m4_define([evo_major_version], [2])
+m4_define([evo_minor_version], [25])
+m4_define([evo_micro_version], [2])
+m4_define([evo_version],
+ [evo_major_version.evo_minor_version.evo_micro_version])
+m4_define([evo_stable_version],
+ [m4_if(m4_eval(evo_minor_version % 2), [1],
+ [evo_major_version.m4_eval(evo_minor_version - 1)],
+ [evo_version])])
+
+AC_INIT(evolution, [evo_version], http://bugzilla.gnome.org/enter_bug.cgi?product=Evolution)
AC_CONFIG_SRCDIR(README)
# Some requirements have versioned package names
@@ -52,6 +62,11 @@ ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
dnl Initialize maintainer mode
AM_MAINTAINER_MODE
+if test "$evo_version" != "$evo_stable_version"; then
+ AC_DEFINE(STABLE_VERSION, ["evo_stable_version"],
+ [Define to the latest stable version if this version is unstable])
+fi
+
dnl *************************************************************************************************
dnl Base Version
dnl
@@ -74,16 +89,6 @@ UPGRADE_REVISION=0
AC_SUBST(UPGRADE_REVISION)
AC_DEFINE_UNQUOTED(UPGRADE_REVISION, "$UPGRADE_REVISION", [The number of times we've upgraded since the BASE_VERSION release])
-dnl *************************************************************************************************
-dnl Development mode
-dnl
-dnl The controls whether things like the development warning in shell/main.c are displayed.
-dnl
-dnl This should be set to 0 for stable releases and 1 for unstable releases
-dnl *************************************************************************************************
-AC_DEFINE(DEVELOPMENT, 1, [If we are in development mode or not])
-AC_SUBST(DEVELOPMENT)
-
AC_ISC_POSIX
AC_PROG_CC
AC_PROG_CPP